BusyBox: Netcat 1.10 compatibility require server option
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 13 Mar 2015 08:38:56 +0000 (08:38 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 13 Mar 2015 08:38:56 +0000 (08:38 +0000)
Netcat 1.10 compatibility require server options

1.10 compatibility without server option
produce error "NO OPT l!" and completely not function

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44746 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/utils/busybox/Makefile
package/utils/busybox/config/networking/Config.in

index fcfdc8b..7421c0a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2014 OpenWrt.org
+#
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.22.1
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 80dd42a..52e38a3 100644 (file)
@@ -67,6 +67,7 @@ config BUSYBOX_CONFIG_NC_110_COMPAT
        bool "Netcat 1.10 compatibility (+2.5k)"
        default BUSYBOX_DEFAULT_NC_110_COMPAT  # off specially for Rob
        depends on BUSYBOX_CONFIG_NC
+       select BUSYBOX_CONFIG_NC_SERVER
        help
          This option makes nc closely follow original nc-1.10.
          The code is about 2.5k bigger. It enables