x86_64: fix PARTUUID format with leading zeros
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Mar 2015 10:06:40 +0000 (10:06 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Mar 2015 10:06:40 +0000 (10:06 +0000)
Otherwise the root device won't be found in 1/16 of the generated images
(whenever the signature starts with a zero digit).

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44959 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/x86_64/image/Makefile

index e8d9ac1..cd80bb1 100644 (file)
@@ -40,7 +40,7 @@ ifneq ($(GRUB_TERMINALS),)
   GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
 endif
 
-SIGNATURE:=$(shell dd if=/dev/urandom bs=4 count=1 2>/dev/null | hexdump -v -e '"%02x"')
+SIGNATURE:=$(shell dd if=/dev/urandom bs=4 count=1 2>/dev/null | hexdump -v -e '"%08x"')
 ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
 ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(SIGNATURE)-02)