[tools] rename patch-cmdline and add code for patching DTB files into kernel images
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Nov 2012 20:06:45 +0000 (20:06 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Nov 2012 20:06:45 +0000 (20:06 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34058 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/patch-cmdline/Makefile [deleted file]
tools/patch-cmdline/src/patch-cmdline.c [deleted file]
tools/patch-image/Makefile [new file with mode: 0644]
tools/patch-image/src/patch-cmdline.c [new file with mode: 0644]
tools/patch-image/src/patch-dtb.c [new file with mode: 0644]

index b3ba6d0..9a0e148 100644 (file)
@@ -15,7 +15,7 @@ tools-y += gmp mpfr mpc libelf
 endif
 tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
-tools-y += firmware-utils patch-cmdline quilt yaffs2 flock padjffs2
+tools-y += firmware-utils patch-image quilt yaffs2 flock padjffs2
 tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake scons
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_powerpc) += upx
diff --git a/tools/patch-cmdline/Makefile b/tools/patch-cmdline/Makefile
deleted file mode 100644 (file)
index a952639..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-# 
-# Copyright (C) 2007-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=patch-cmdline
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Compile
-       $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/$(PKG_NAME) src/$(PKG_NAME).c
-endef
-
-define Host/Install
-       $(CP) $(HOST_BUILD_DIR)/patch-cmdline $(STAGING_DIR_HOST)/bin/
-endef
-
-define Host/Clean
-       rm -f $(STAGING_DIR_HOST)/bin/patch-cmdline
-endef
-
-$(eval $(call HostBuild))
diff --git a/tools/patch-cmdline/src/patch-cmdline.c b/tools/patch-cmdline/src/patch-cmdline.c
deleted file mode 100644 (file)
index 571f848..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-/*
- * patch-cmdline.c - patch the kernel command line on rb532
- *
- * Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License
- * as published by the Free Software Foundation; either version 2
- * of the License, or (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
- *
- */
-
-#include <stdio.h>
-#include <stdlib.h>
-#include <stddef.h>
-#include <unistd.h>
-#include <fcntl.h>
-#include <sys/mman.h>
-#include <sys/stat.h>
-#include <string.h>
-
-#define SEARCH_SPACE   (16 * 1024)
-#define CMDLINE_MAX            512
-
-int main(int argc, char **argv)
-{
-       int fd, found = 0, len, ret = -1;
-       char *ptr, *p;
-
-       if (argc != 3) {
-               fprintf(stderr, "Usage: %s <file> <cmdline>\n", argv[0]);
-               goto err1;
-       }
-       len = strlen(argv[2]);
-       if (len + 9 > CMDLINE_MAX) {
-               fprintf(stderr, "Command line string too long\n");
-               goto err1;
-       }
-       
-       if (((fd = open(argv[1], O_RDWR)) < 0) ||
-               (ptr = (char *) mmap(0, SEARCH_SPACE + CMDLINE_MAX, PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0)) == (void *) (-1)) {
-               fprintf(stderr, "Could not open kernel image");
-               goto err2;
-       }
-       
-       for (p = ptr; p < (ptr + SEARCH_SPACE); p += 4) {
-               if (memcmp(p, "CMDLINE:", 8) == 0) {
-                       found = 1;
-                       p += 8;
-                       break;
-               }
-       }
-       if (!found) {
-               fprintf(stderr, "Command line marker not found!\n");
-               goto err3;
-       }
-
-       memset(p, 0, CMDLINE_MAX - 8);
-       strcpy(p, argv[2]);
-       msync(p, CMDLINE_MAX, MS_SYNC|MS_INVALIDATE);
-       ret = 0;
-
-err3:
-       munmap((void *) ptr, len);
-err2:
-       if (fd > 0)
-               close(fd);
-err1:
-       return ret;
-}
diff --git a/tools/patch-image/Makefile b/tools/patch-image/Makefile
new file mode 100644 (file)
index 0000000..cd2df5c
--- /dev/null
@@ -0,0 +1,28 @@
+# 
+# Copyright (C) 2007-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=patch-image
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+       $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/patch-cmdline src/patch-cmdline.c
+       $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/patch-dtb src/patch-dtb.c
+endef
+
+define Host/Install
+       $(CP) $(HOST_BUILD_DIR)/patch-cmdline $(STAGING_DIR_HOST)/bin/
+       $(CP) $(HOST_BUILD_DIR)/patch-dtb $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/patch-cmdline
+       rm -f $(STAGING_DIR_HOST)/bin/patch-dtb
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/patch-image/src/patch-cmdline.c b/tools/patch-image/src/patch-cmdline.c
new file mode 100644 (file)
index 0000000..571f848
--- /dev/null
@@ -0,0 +1,79 @@
+/*
+ * patch-cmdline.c - patch the kernel command line on rb532
+ *
+ * Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
+ *
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <stddef.h>
+#include <unistd.h>
+#include <fcntl.h>
+#include <sys/mman.h>
+#include <sys/stat.h>
+#include <string.h>
+
+#define SEARCH_SPACE   (16 * 1024)
+#define CMDLINE_MAX            512
+
+int main(int argc, char **argv)
+{
+       int fd, found = 0, len, ret = -1;
+       char *ptr, *p;
+
+       if (argc != 3) {
+               fprintf(stderr, "Usage: %s <file> <cmdline>\n", argv[0]);
+               goto err1;
+       }
+       len = strlen(argv[2]);
+       if (len + 9 > CMDLINE_MAX) {
+               fprintf(stderr, "Command line string too long\n");
+               goto err1;
+       }
+       
+       if (((fd = open(argv[1], O_RDWR)) < 0) ||
+               (ptr = (char *) mmap(0, SEARCH_SPACE + CMDLINE_MAX, PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0)) == (void *) (-1)) {
+               fprintf(stderr, "Could not open kernel image");
+               goto err2;
+       }
+       
+       for (p = ptr; p < (ptr + SEARCH_SPACE); p += 4) {
+               if (memcmp(p, "CMDLINE:", 8) == 0) {
+                       found = 1;
+                       p += 8;
+                       break;
+               }
+       }
+       if (!found) {
+               fprintf(stderr, "Command line marker not found!\n");
+               goto err3;
+       }
+
+       memset(p, 0, CMDLINE_MAX - 8);
+       strcpy(p, argv[2]);
+       msync(p, CMDLINE_MAX, MS_SYNC|MS_INVALIDATE);
+       ret = 0;
+
+err3:
+       munmap((void *) ptr, len);
+err2:
+       if (fd > 0)
+               close(fd);
+err1:
+       return ret;
+}
diff --git a/tools/patch-image/src/patch-dtb.c b/tools/patch-image/src/patch-dtb.c
new file mode 100644 (file)
index 0000000..161e1dc
--- /dev/null
@@ -0,0 +1,101 @@
+/*
+ * patch-dtb.c - patch a dtb into an image
+ *
+ * Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
+ * Copyright (C) 2012 John Crispin <blogic@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
+ *
+ * based on patch-cmdline.c
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <stddef.h>
+#include <unistd.h>
+#include <fcntl.h>
+#include <sys/mman.h>
+#include <sys/stat.h>
+#include <string.h>
+
+#define SEARCH_SPACE   (16 * 1024)
+#define DTB_MAX        (16 * 1024)
+
+int main(int argc, char **argv)
+{
+       int fd, fddtb, found = 0, len, ret = -1;
+       char *ptr, *ptrdtb, *p;
+       struct stat s;
+
+       if (argc != 3) {
+               fprintf(stderr, "Usage: %s <file> <dtb>\n", argv[0]);
+               goto err1;
+       }
+       fddtb = open(argv[1], O_RDONLY);
+       if (!fddtb)
+               goto err1;
+
+       if (stat(argv[2], &s)) {
+               fprintf(stderr, "DTB not found\n");
+               goto err1;
+       }
+
+       len = s.st_size;
+       if (len + 8 > DTB_MAX) {
+               fprintf(stderr, "DTB too big\n");
+               goto err1;
+       }
+
+        if (((fddtb = open(argv[2], O_RDONLY)) < 0) ||
+               (ptrdtb = (char *) mmap(0, DTB_MAX, PROT_READ, MAP_SHARED, fddtb, 0)) == (void *) (-1)) {
+               fprintf(stderr, "Could not open DTB");
+               goto err2;
+       }
+
+       if (((fd = open(argv[1], O_RDWR)) < 0) ||
+               (ptr = (char *) mmap(0, SEARCH_SPACE + DTB_MAX, PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0)) == (void *) (-1)) {
+               fprintf(stderr, "Could not open kernel image");
+               goto err3;
+       }
+
+       for (p = ptr; p < (ptr + SEARCH_SPACE); p += 4) {
+               if (memcmp(p, "OWRTDTB:", 8) == 0) {
+                       found = 1;
+                       p += 8;
+                       break;
+               }
+       }
+       if (!found) {
+               fprintf(stderr, "DTB marker not found!\n");
+               goto err4;
+       }
+
+       memset(p, 0, DTB_MAX - 8);
+       memcpy(p, ptrdtb, len);
+       msync(p, len, MS_SYNC|MS_INVALIDATE);
+       ret = 0;
+
+err4:
+       munmap((void *) ptr, len);
+err3:
+       if (fd > 0)
+               close(fd);
+       munmap((void *) ptrdtb, len);
+err2:
+       if (fddtb > 0)
+               close(fddtb);
+err1:
+       return ret;
+}