ramips: rt305x: add kernel support for AirLive AIR3GII
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 29 Dec 2012 17:50:28 +0000 (17:50 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 29 Dec 2012 17:50:28 +0000 (17:50 +0000)
AirLive AIR3GII is Ralink RT5350F based device with
100Mbps switch, USB port, 4MB flash and 32MB ram.

Works: ethernet (LAN & WAN), wps button, led, USB, sysupgrade
Does not work: wifi (chip RT5350), reset button

[   13.390000] phy0 -> rt2800_init_eeprom: Error - Invalid RT chipset 0x5350 detected.
[   13.400000] phy0 -> rt2x00lib_probe_dev: Error - Failed to allocate device.

Other problem: LAN leds is reverse (lights when not cable
connected and vice versa)

[juhosg: move user-space support and image generation changes into
separate patches]

Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com>
Patchwork: http://patchwork.openwrt.org/patch/2913/
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34922 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-air3gii.c [new file with mode: 0644]
target/linux/ramips/rt305x/config-3.6
target/linux/ramips/rt305x/config-3.7

index f8dbcbc..5c2d712 100644 (file)
@@ -75,5 +75,8 @@ enum ramips_mach_type {
 
        /* RT3883 based machines */
        RAMIPS_MACH_TEW_691GR,          /* TRENDnet TEW-691GR */
-       RAMIPS_MACH_TEW_692GR           /* TRENDnet TEW-692GR */
+       RAMIPS_MACH_TEW_692GR,          /* TRENDnet TEW-692GR */
+
+       /* RT5350 based machines */
+       RAMIPS_MACH_AIR3GII,            /* AirLive Air3GII */
 };
index 769603d..d0c1fdb 100644 (file)
@@ -17,6 +17,11 @@ config RT305X_MACH_WR6202
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_AIR3GII
+       bool "AirLive Air3GII board support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_ALL0256N
        bool "Allnet ALL0256N support"
        select RALINK_DEV_GPIO_BUTTONS
index c61fba8..321542d 100644 (file)
@@ -14,6 +14,7 @@ obj-$(CONFIG_EARLY_PRINTK)            += early_printk.o
 obj-$(CONFIG_RT305X_MACH_3G_6200N)     += mach-3g-6200n.o
 obj-$(CONFIG_RT305X_MACH_ARGUS_ATP52B) += mach-argus-atp52b.o
 obj-$(CONFIG_RT305X_MACH_BC2)          += mach-bc2.o
+obj-$(CONFIG_RT305X_MACH_AIR3GII)      += mach-air3gii.o
 obj-$(CONFIG_RT305X_MACH_ALL0256N)     += mach-all0256n.o
 obj-$(CONFIG_RT305X_MACH_ALL5002)      += mach-all5002.o
 obj-$(CONFIG_RT305X_MACH_BROADWAY)     += mach-broadway.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-air3gii.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-air3gii.c
new file mode 100644 (file)
index 0000000..aca238a
--- /dev/null
@@ -0,0 +1,94 @@
+/*
+ *  AirLive Air3GII board support
+ *
+ *  Copyright (C) 2012 Cezary Jackiewicz <cezary.jackiewicz@gmail.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define AIR3GII_GPIO_BUTTON_WPS 7
+
+#define AIR3GII_GPIO_LED_WLAN   8
+#define AIR3GII_GPIO_LED_MOBILE 9
+
+#define AIR3GII_KEYS_POLL_INTERVAL   20
+#define AIR3GII_KEYS_DEBOUNCE_INTERVAL (3 * AIR3GII_KEYS_POLL_INTERVAL)
+
+const struct flash_platform_data air3gii_flash = {
+       .type           = "en25q32b",
+};
+
+struct spi_board_info air3gii_spi_slave_info[] __initdata = {
+       {
+               .modalias       = "m25p80",
+               .platform_data  = &air3gii_flash,
+               .irq            = -1,
+               .max_speed_hz   = 10000000,
+               .bus_num        = 0,
+               .chip_select    = 0,
+       },
+};
+
+static struct gpio_led air3gii_leds_gpio[] __initdata = {
+       {
+               .name           = "airlive:green:wlan",
+               .gpio           = AIR3GII_GPIO_LED_WLAN,
+               .active_low     = 0,
+       }, {
+               .name           = "airlive:green:mobile",
+               .gpio           = AIR3GII_GPIO_LED_MOBILE,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button air3gii_gpio_buttons[] __initdata = {
+       {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = AIR3GII_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = AIR3GII_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       }
+};
+
+static void __init air3gii_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+       rt305x_register_spi(air3gii_spi_slave_info,
+                           ARRAY_SIZE(air3gii_spi_slave_info));
+
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+       rt305x_register_ethernet();
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(air3gii_leds_gpio),
+                                 air3gii_leds_gpio);
+
+       ramips_register_gpio_buttons(-1, AIR3GII_KEYS_POLL_INTERVAL,
+                                    ARRAY_SIZE(air3gii_gpio_buttons),
+                                    air3gii_gpio_buttons);
+
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+       rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_AIR3GII, "AIR3GII", "AirLive Air3GII",
+               air3gii_init);
index 1971c2a..8d62667 100644 (file)
@@ -93,6 +93,7 @@ CONFIG_RALINK_RT305X=y
 # CONFIG_RALINK_RT3883 is not set
 CONFIG_RAMIPS_WDT=y
 CONFIG_RT305X_MACH_3G_6200N=y
+CONFIG_RT305X_MACH_AIR3GII=y
 CONFIG_RT305X_MACH_ALL0256N=y
 CONFIG_RT305X_MACH_ALL5002=y
 CONFIG_RT305X_MACH_ARGUS_ATP52B=y
index 93edafd..4947aef 100644 (file)
@@ -103,6 +103,7 @@ CONFIG_RALINK_RT305X=y
 # CONFIG_RALINK_RT3883 is not set
 CONFIG_RAMIPS_WDT=y
 CONFIG_RT305X_MACH_3G_6200N=y
+CONFIG_RT305X_MACH_AIR3GII=y
 CONFIG_RT305X_MACH_ALL0256N=y
 CONFIG_RT305X_MACH_ALL5002=y
 CONFIG_RT305X_MACH_ARGUS_ATP52B=y