add a host package for xz
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 11 Dec 2010 13:20:19 +0000 (13:20 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 11 Dec 2010 13:20:19 +0000 (13:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24481 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/xz/Makefile [new file with mode: 0644]

index e96167b..3b3f187 100644 (file)
@@ -17,7 +17,7 @@ endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
-tools-y += xorg-macros
+tools-y += xorg-macros xz
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_TARGET_ar71xx),)
diff --git a/tools/xz/Makefile b/tools/xz/Makefile
new file mode 100644 (file)
index 0000000..5689e18
--- /dev/null
@@ -0,0 +1,18 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xz
+PKG_VERSION:=5.0.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://tukaani.org/xz
+PKG_MD5SUM:=0652c09fdbb93ae2ce78c1368ffda612
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))