Also package exportfs for nfsd to work properly on 2.6 kernels (#1899)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Jun 2007 07:45:33 +0000 (07:45 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Jun 2007 07:45:33 +0000 (07:45 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7627 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/fs.mk

index f28c9ad..3e8cd7c 100644 (file)
@@ -106,10 +106,19 @@ define KernelPackage/fs-nfsd
   DESCRIPTION:=Kernel module for NFS kernel server support
   KCONFIG:=$(CONFIG_NFSD)
   SUBMENU:=$(FSMENU)
-  AUTOLOAD:=$(call AutoLoad,30,nfsd)
   FILES:= \
        $(LINUX_DIR)/fs/nfsd/nfsd.$(LINUX_KMOD_SUFFIX)
 endef
+
+define KernelPackage/fs-nfsd/2.4
+  AUTOLOAD:=$(call AutoLoad,30,nfsd)
+endef
+
+define KernelPackage/fs-nfsd/2.6
+  FILES+=$(LINUX_DIR)/fs/exportfs/exportfs.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,exportfs nfsd)
+endef
+
 $(eval $(call KernelPackage,fs-nfsd))
 
 define KernelPackage/fs-msdos