image: append-ubi: add optional UBI subpage size
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Nov 2015 13:19:35 +0000 (13:19 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Nov 2015 13:19:35 +0000 (13:19 +0000)
Signed-off-by: Claudio Leite <leitec@staticky.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47411 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index a6ea8e5..fd5e3f4 100644 (file)
@@ -384,7 +384,8 @@ define Build/append-ubi
                $(if $(KERNEL_IN_UBI),--kernel $(word 1,$^)) \
                $(word 2,$^) \
                $@.tmp \
-               -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5
+               -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5 \
+               $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE))
        cat $@.tmp >> $@
        rm $@.tmp
 endef