tools/cmake: update to 3.5.1
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Apr 2016 12:52:37 +0000 (12:52 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Apr 2016 12:52:37 +0000 (12:52 +0000)
Update cmake to 3.5.1

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49186 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/cmake/Makefile
tools/cmake/patches/100-disable_qt_tests.patch
tools/cmake/patches/110-freebsd-compat.patch

index d7a68ea..3cbc09e 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cmake
-PKG_VERSION:=3.4.3
+PKG_VERSION:=3.5.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://cmake.org/files/v3.4/ \
+PKG_SOURCE_URL:=https://cmake.org/files/v3.5/ \
                https://fossies.org/linux/misc/
-PKG_MD5SUM:=4cb3ff35b2472aae70f542116d616e63
+PKG_MD5SUM:=ca051f4a66375c89d1a524e726da0296
 
 HOST_BUILD_PARALLEL:=1
 HOST_CONFIGURE_PARALLEL:=1
index 417e27a..9d2f641 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Tests/RunCMake/CMakeLists.txt
 +++ b/Tests/RunCMake/CMakeLists.txt
-@@ -216,15 +216,6 @@
+@@ -217,15 +217,6 @@ add_RunCMake_test(interface_library)
  add_RunCMake_test(no_install_prefix)
  add_RunCMake_test(configure_file)
  
@@ -18,7 +18,7 @@
    add_RunCMake_test(FindPkgConfig)
 --- a/Tests/CMakeLists.txt
 +++ b/Tests/CMakeLists.txt
-@@ -390,10 +390,6 @@
+@@ -389,10 +389,6 @@ if(BUILD_TESTING)
  
    list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
  
index b549448..49c9b78 100644 (file)
@@ -19,8 +19,6 @@ Change-Id: I3b91ed7ac0e6878035aee202b3336c536cc6d2ff
  Source/kwsys/SystemInformation.cxx |    9 +++++++++
  1 file changed, 9 insertions(+)
 
-diff --git a/Source/kwsys/SystemInformation.cxx b/Source/kwsys/SystemInformation.cxx
-index 7c31f3a..2672730 100644
 --- a/Source/kwsys/SystemInformation.cxx
 +++ b/Source/kwsys/SystemInformation.cxx
 @@ -90,6 +90,15 @@ typedef int siginfo_t;
@@ -39,4 +37,3 @@ index 7c31f3a..2672730 100644
  #endif
  
  #if defined(__OpenBSD__) || defined(__NetBSD__)
-