package/kernel: add IKCONFIG module option
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 19 Oct 2012 17:47:22 +0000 (17:47 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 19 Oct 2012 17:47:22 +0000 (17:47 +0000)
Add an option for building the configs.ko module which provides
kernel configuration via /proc/config.gz

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33865 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk

index f370f65..352af28 100644 (file)
@@ -697,3 +697,18 @@ define KernelPackage/regmap/description
 endef
 
 $(eval $(call KernelPackage,regmap))
+
+define KernelPackage/ikconfig
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Kernel configuration via /proc/config.gz
+  KCONFIG:=CONFIG_IKCONFIG \
+          CONFIG_IKCONFIG_PROC=y
+  FILES:=$(LINUX_DIR)/kernel/configs.ko
+  AUTOLOAD:=$(call AutoLoad,70,configs)
+endef
+
+define KernelPackage/ikconfig/description
+       Kernel configuration via /proc/config.gz
+endef
+
+$(eval $(call KernelPackage,ikconfig))