odhcp6c: Add option to override interface identifier in RA-client
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 18 Jun 2013 12:51:14 +0000 (12:51 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 18 Jun 2013 12:51:14 +0000 (12:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36959 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.sh

index 125dea8..9d39fdf 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-06-13
+PKG_VERSION:=2013-06-18
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=83114b179091cb080f09cf4142ee1c9949ea4e30
+PKG_SOURCE_VERSION:=eaf3a11cad8a5dd389d5f52cc76e424e0242074b
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
 include $(INCLUDE_DIR)/package.mk
index b2264ed..c5e77c6 100755 (executable)
@@ -18,8 +18,8 @@ proto_dhcpv6_setup() {
        local config="$1"
        local iface="$2"
 
-       local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite
-       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite
+       local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
+       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
 
 
        # Configure
@@ -35,6 +35,8 @@ proto_dhcpv6_setup() {
 
        [ "$norelease" = "1" ] && append opts "-k"
 
+       [ -n "$ifaceid" ] && append opts "-i$ifaceid"
+
        for opt in $reqopts; do
                append opts "-r$opt"
        done