ramips: board support for Asus RT-N10+
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Mar 2012 16:09:11 +0000 (16:09 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Mar 2012 16:09:11 +0000 (16:09 +0000)
[juhosg: fix indentation in platform scripts, and remove debug
messages from 06_set_iface_mac]

Signed-off-by: Patrick van Staveren <trick@vanstaveren.us>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30808 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-rt-n10-plus.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-3.2

index 26f0d1f..0a13ddb 100755 (executable)
@@ -66,6 +66,9 @@ get_status_led() {
        rt-n15)
                status_led="rt-n15:blue:power"
                ;;
+       rt-n10-plus)
+               status_led="asus:green:wps"
+               ;;
        rt-n56u)
                status_led="asus:blue:power"
                ;;
index eb756a5..148fda2 100644 (file)
@@ -38,6 +38,7 @@ case "$FIRMWARE" in
                rt2x00_eeprom_extract "devdata" 16384 272
                ;;
 
+       rt-n10-plus | \
        rt-g32-b1)
                rt2x00_eeprom_extract "devconf" 0 272
                ;;
index 66eb6b9..cb9c7ab 100644 (file)
@@ -36,6 +36,10 @@ preinit_set_mac_address() {
                mac=$(ramips_get_mac_binary board-nvram 65440)
                ifconfig eth0 hw ether $mac 2>/dev/null
                ;;
+       rt-n10-plus)
+               mac=$(ramips_get_mac_binary devconf 4)
+               ifconfig eth0 hw ether $mac 2>/dev/null
+               ;;
        esac
 }
 
index 728f525..3567209 100755 (executable)
@@ -98,6 +98,9 @@ ramips_board_name() {
        *"RT-G32 B1")
                name="rt-g32-b1"
                ;;
+       *"RT-N10+")
+               name="rt-n10-plus"
+               ;;
        *"RT-N15")
                name="rt-n15"
                ;;
index a2f3513..1f6910d 100755 (executable)
@@ -27,6 +27,7 @@ platform_check_image() {
        nw718 | \
        omni-emb | \
        rt-g32-b1 | \
+       rt-n10-plus | \
        rt-n15 | \
        rt-n56u | \
        sl-r7205 | \
index ac7aac4..cfb6bc6 100644 (file)
@@ -26,6 +26,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_DIR_600_B1,         /* D-Link DIR-600 B1 */
        RAMIPS_MACH_DIR_600_B2,         /* D-Link DIR-600 B2 */
        RAMIPS_MACH_RT_G32_B1,          /* Asus RT-G32 B1 */
+       RAMIPS_MACH_RT_N10_PLUS,        /* Asus RT-N10+ */
        RAMIPS_MACH_NW718,              /* Netcore NW718 */
 
        /* RT3052 based machines */
index 1644832..ae05190 100644 (file)
@@ -26,6 +26,11 @@ config RT305X_MACH_RT_G32_REVB
        bool "Asus RT-G32 revB board support"
        select RALINK_DEV_GPIO_BUTTONS
 
+config RT305X_MACH_RT_N10_PLUS
+       bool "Asus RT-N10+ board support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_HW550_3G
        bool "Aztech HW550-3G support"
        select RALINK_DEV_GPIO_BUTTONS
index c8b0289..ce1d568 100644 (file)
@@ -25,6 +25,7 @@ obj-$(CONFIG_RT305X_MACH_NW718)               += mach-nw718.o
 obj-$(CONFIG_RT305X_MACH_OMNI_EMB)     += mach-omni-emb.o
 obj-$(CONFIG_RT305X_MACH_PWH2004)      += mach-pwh2004.o
 obj-$(CONFIG_RT305X_MACH_RT_G32_REVB)  += mach-rt-g32-revb.o
+obj-$(CONFIG_RT305X_MACH_RT_N10_PLUS)  += mach-rt-n10-plus.o
 obj-$(CONFIG_RT305X_MACH_SL_R7205)     += mach-sl-r7205.o
 obj-$(CONFIG_RT305X_MACH_V22RW_2X2)    += mach-v22rw-2x2.o
 obj-$(CONFIG_RT305X_MACH_W502U)                += mach-w502u.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-rt-n10-plus.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-rt-n10-plus.c
new file mode 100644 (file)
index 0000000..5b496d4
--- /dev/null
@@ -0,0 +1,74 @@
+/*
+ *  ASUS RT-N10+ board support
+ *
+ *  Copyright (C) 2009-2012 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define RT_N10_PLUS_GPIO_LED_WPS       14
+
+#define RT_N10_PLUS_GPIO_BUTTON_WPS    0       /* active low */
+#define RT_N10_PLUS_GPIO_BUTTON_RESET  10      /* active low */
+
+#define RT_N10_PLUS_KEYS_POLL_INTERVAL 20
+#define RT_N10_PLUS_KEYS_DEBOUNCE_INTERVAL  (3 * RT_N10_PLUS_KEYS_POLL_INTERVAL)
+
+static struct gpio_led rt_n10_plus_leds_gpio[] __initdata = {
+       {
+               .name           = "asus:green:wps",
+               .gpio           = RT_N10_PLUS_GPIO_LED_WPS,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button rt_n10_plus_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = RT_N10_PLUS_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = RT_N10_PLUS_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = RT_N10_PLUS_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = RT_N10_PLUS_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       }
+};
+
+static void __init rt_n10_plus_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+       rt305x_register_flash(0);
+
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
+       rt305x_register_ethernet();
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(rt_n10_plus_leds_gpio),
+                                 rt_n10_plus_leds_gpio);
+       ramips_register_gpio_buttons(-1, RT_N10_PLUS_KEYS_POLL_INTERVAL,
+                                    ARRAY_SIZE(rt_n10_plus_gpio_buttons),
+                                    rt_n10_plus_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_RT_N10_PLUS, "RT-N10-PLUS", "Asus RT-N10+",
+       rt_n10_plus_init);
index 031b03a..bb6124c 100644 (file)
@@ -205,6 +205,13 @@ define BuildFirmware/RTG32B1
        $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/spi,$(mtdlayout_rtg32b1)),$(mtd_rtg32b1_kernel_part_size),$(mtd_rtg32b1_rootfs_part_size))
 endef
 
+mtdlayout_rtn10plus=192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,896k(kernel),2880k(rootfs),3776k@0x50000(firmware)
+mtd_rtn10plus_kernel_part_size=917504
+mtd_rtn10plus_rootfs_part_size=2949120
+define BuildFirmware/RTN10PLUS
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_rtn10plus)),$(mtd_rtn10plus_kernel_part_size),$(mtd_rtn10plus_rootfs_part_size))
+endef
+
 mtdlayout_whrg300n=192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,960k(kernel),2752k(rootfs),64k(user)ro,3712k@0x50000(firmware)
 define BuildFirmware/WHRG300N
        $(call Image/Build/Template/GENERIC_4M,$(1),whr-g300n,WHR-G300N,ttyS1,57600,phys)
@@ -343,6 +350,10 @@ define Image/Build/Profile/RTG32B1
        $(call Image/Build/Template/$(fs_squash)/$(1),RTG32B1,rt-g32-b1,RT-G32-B1)
 endef
 
+define Image/Build/Profile/RTN10PLUS
+       $(call Image/Build/Template/$(fs_squash)/$(1),RTN10PLUS,rt-n10-plus,RT-N10-PLUS)
+endef
+
 define Image/Build/Profile/SLR7205
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,sl-r7205,SL-R7205,ttyS1,57600,phys)
 endef
@@ -388,6 +399,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/DIR300B1,$(1))
        $(call Image/Build/Profile/ESR9753,$(1))
        $(call Image/Build/Profile/F5D8235V2,$(1))
+       $(call Image/Build/Profile/RTN10PLUS,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
        $(call Image/Build/Profile/HW5503G,$(1))
        $(call Image/Build/Profile/MOFI35003GN,$(1))
index c44dba3..09355dd 100644 (file)
@@ -107,6 +107,7 @@ CONFIG_RT305X_MACH_NW718=y
 CONFIG_RT305X_MACH_OMNI_EMB=y
 CONFIG_RT305X_MACH_PWH2004=y
 CONFIG_RT305X_MACH_RT_G32_REVB=y
+CONFIG_RT305X_MACH_RT_N10_PLUS=y
 CONFIG_RT305X_MACH_SL_R7205=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
 CONFIG_RT305X_MACH_W502U=y