openssl: Pass in any TARGET_ASFLAGS
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 5 Apr 2013 12:36:09 +0000 (12:36 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 5 Apr 2013 12:36:09 +0000 (12:36 +0000)
Packages not picking up the regular TARGET_AS need their openwrt
Makefiles tweaked. For a basic build, that's just openssl.

This depends on patch 1/5.

Signed-off-by: Jay Carlson <nop@nop.com>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36201 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/openssl/Makefile

index a8b3257..049aad4 100644 (file)
@@ -124,6 +124,7 @@ define Build/Compile
                depend
        $(_SINGLE)$(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
+               ASFLAGS="$(TARGET_ASFLAGS) -c" \
                AR="$(TARGET_CROSS)ar r" \
                RANLIB="$(TARGET_CROSS)ranlib" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
@@ -131,6 +132,7 @@ define Build/Compile
                all
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
+               ASFLAGS="$(TARGET_ASFLAGS) -c" \
                AR="$(TARGET_CROSS)ar r" \
                RANLIB="$(TARGET_CROSS)ranlib" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \