kernel: add uinput module
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 Apr 2015 14:31:02 +0000 (14:31 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 Apr 2015 14:31:02 +0000 (14:31 +0000)
This module is needed for bluetooth audio playback
with pulseaudio 6 and bluez5.

a working guide can be found in the wiki:
http://wiki.openwrt.org/wiki/bluetooth.audio
(additional packages/modifications are required
and submitted to github feeds)

tested with:
Android mobile (Sony Xperia M) as audio source
TI omap BeagleBoard as audio sink

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45231 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/input.mk

index b44136b..86ff33c 100644 (file)
@@ -205,3 +205,21 @@ define KernelPackage/keyboard-imx/description
 endef
 
 $(eval $(call KernelPackage,keyboard-imx))
+
+
+define KernelPackage/input-uinput
+  SUBMENU:=$(INPUT_MODULES_MENU)
+  TITLE:=user input module
+  DEPENDS:=+kmod-input-core
+  KCONFIG:= \
+       CONFIG_INPUT_MISC=y \
+       CONFIG_INPUT_UINPUT
+  FILES:=$(LINUX_DIR)/drivers/input/misc/uinput.ko
+  AUTOLOAD:=$(call AutoProbe,uinput)
+endef
+
+define KernelPackage/input-uinput/description
+  user input modules needed for bluez
+endef
+
+$(eval $(call KernelPackage,input-uinput))