cleanup
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Oct 2006 22:11:21 +0000 (22:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Oct 2006 22:11:21 +0000 (22:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5097 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/sstrip/Makefile
tools/sstrip/src/sstrip.c

index 4e409e0..87f3312 100644 (file)
@@ -13,6 +13,7 @@ OS:=$(shell uname)
 ifeq ($(HOST_OS),Darwin)
   CFLAGS += -I./include
 endif
+CFLAGS += -I $(TOPDIR)/tools/include -include endian.h
 
 define Build/Compile
        $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c
index 60c12c9..6607d12 100644 (file)
 #include       <fcntl.h>
 #include       <elf.h>
 
-#ifdef __FreeBSD__
-/**
- * This seems to work on FreeBSD 5.3, should
- * work on all newer versions as well. I have
- * no idea if it will work on versions < 5.3
- *
- * Joe Estock (guru) <jestock at nutextonline.com>
- */
-#include <sys/endian.h>
-#define bswap_64 __bswap64
-#define bswap_32 __bswap32
-#define bswap_16 __bswap16
-#elif defined(__APPLE__)
-#include       <machine/endian.h>
-#include       <machine/byte_order.h>
-#define __BYTE_ORDER BYTE_ORDER
-#define __BIG_ENDIAN BIG_ENDIAN
-#define bswap_16(x) NXSwapShort(x)
-#define bswap_32(x) NXSwapInt(x)
-#define bswap_64(x) NXSwapLongLong(x)
-#else
-#include       <endian.h>
-#include       <byteswap.h>
-#endif 
-
-
 #ifndef TRUE
 #define        TRUE            1
 #define        FALSE           0