brcm63xx: add DT support for F@ST2604
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Dec 2014 00:50:59 +0000 (00:50 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Dec 2014 00:50:59 +0000 (00:50 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43448 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/dts/fast2604.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
target/linux/brcm63xx/profiles/sagem.mk

diff --git a/target/linux/brcm63xx/dts/fast2604.dts b/target/linux/brcm63xx/dts/fast2604.dts
new file mode 100644 (file)
index 0000000..5dcaa55
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+       model = "Sagem F@ST2604";
+       compatible = "sagem,f@st2604", "brcm,bcm6348";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x3e0000>;
+       };
+
+       nvram@3f0000 {
+               label = "nvram";
+               reg = <0x3f0000 0x010000>;
+       };
+};
index 812e741..21e3825 100755 (executable)
@@ -220,9 +220,6 @@ define Image/Build
        # TP-Link 8900GB
        $(call Image/Build/CFE,$(1),96348GW-11,6348,TD8900GB,$(shell printf 'PRID\x89\x10\x00\x02'))
 
-       # Sagem F@ST2604
-       $(call Image/Build/CFE,$(1),F@ST2604,6348,F@ST2604-cfe)
-       $(call Image/Build/CFE,$(1),F@ST2604,6348,F@ST2604,OpenWRT-$(REVISION))
        # Sagem F@ST2704V2
        $(call Image/Build/CFE,$(1),F@ST2704V2,6328,F@ST2704V2-cfe)
        $(call Image/Build/CFE,$(1),F@ST2704V2,6328,F@ST2704V2,OpenWRT-$(REVISION))
@@ -325,6 +322,8 @@ $(eval $(call ImageDTB,CFEDTB,A226M,a226m,DWV-S0,6358,A226M,--signature2 IMAGE -
 $(eval $(call ImageDTB,CFEDTB,A226M,a226m-fwb,DWV-S0,6358,A226M-FWB,--block-size 0x20000 --image-offset 0x20000 --signature2 IMAGE --tag-version 8))
 # Sagem F@ST2404
 $(eval $(call ImageDTB,CFEDTB,FAST2404,fast2404,F@ST2404,6348,F@ST2404))
+# Sagem F@ST2604
+$(eval $(call ImageDTB,CFEDTB,FAST2604,fast2604,F@ST2604,6348,F@ST2604))
 # T-Com Speedport W 303V Typ B
 $(eval $(call ImageDTB,SPW303VCFEDTB,SPW303V,spw303v,96358-502V,6358,SPW303V,--pad 4))
 # T-Com Speedport W 500V
index 6ded2f9..87093d7 100644 (file)
        &board_DV201AMR,
        &board_96348gw_a,
        &board_rta1025w_16,
+@@ -2711,6 +2763,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
+       { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
+       { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
++      { .compatible = "sagem,f@st2604", .data = &board_FAST2604, },
+       { .compatible = "t-com,spw500v", .data = &board_spw500v, },
+       { .compatible = "tecom,gw6000", .data = &board_gw6000, },
+       { .compatible = "tecom,gw6200", .data = &board_gw6200, },
index 94cb056..17686d3 100644 (file)
@@ -13,3 +13,12 @@ define Profile/FAST2404/Description
   Package set optimized for F@ST2404.
 endef
 $(eval $(call Profile,FAST2404))
+
+define Profile/FAST2604
+  NAME:=Sagem F@ST2604
+  PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/FAST2604/Description
+  Package set optimized for F@ST2604.
+endef
+$(eval $(call Profile,FAST2604))