sunxi: move pcduino3 dts into patches [3.14]
authorwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 4 Nov 2014 20:20:38 +0000 (20:20 +0000)
committerwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 4 Nov 2014 20:20:38 +0000 (20:20 +0000)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43180 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/sunxi/files/arch/arm/boot/dts/sun7i-a20-pcduino3.dts [deleted file]
target/linux/sunxi/patches-3.14/300-1-dt-sun7i-add-pcduino3.patch [new file with mode: 0644]
target/linux/sunxi/patches-3.14/300-2-dt-sun7i-add-pcduino3-dts.patch [new file with mode: 0644]
target/linux/sunxi/patches-3.14/300-dt-sun7i-add-pcduino3.patch [deleted file]

diff --git a/target/linux/sunxi/files/arch/arm/boot/dts/sun7i-a20-pcduino3.dts b/target/linux/sunxi/files/arch/arm/boot/dts/sun7i-a20-pcduino3.dts
deleted file mode 100644 (file)
index 85a6936..0000000
+++ /dev/null
@@ -1,153 +0,0 @@
-/*
- * Copyright 2014 Zoltan HERPAI
- * Zoltan HERPAI <wigyori@uid0.hu>
- *
- * The code contained herein is licensed under the GNU General Public
- * License. You may obtain a copy of the GNU General Public License
- * Version 2 or later at the following locations:
- *
- * http://www.opensource.org/licenses/gpl-license.html
- * http://www.gnu.org/copyleft/gpl.html
- */
-
-/dts-v1/;
-/include/ "sun7i-a20.dtsi"
-/include/ "sunxi-ahci-reg.dtsi"
-/include/ "sun4i-a10-usb-vbus-reg.dtsi"
-#include <dt-bindings/input/input.h>
-
-/ {
-       model = "LinkSprite pcDuino V3";
-       compatible = "linksprite,a20-pcduino", "allwinner,sun7i-a20";
-
-       aliases {
-               spi0 = &spi1;
-               spi1 = &spi2;
-       };
-
-       soc@01c00000 {
-               spi1: spi@01c06000 {
-                       pinctrl-names = "default";
-                       pinctrl-0 = <&spi1_pins_a>;
-                       status = "okay";
-               };
-
-               spi2: spi@01c17000 {
-                       pinctrl-names = "default";
-                       pinctrl-0 = <&spi2_pins_a>;
-                       status = "okay";
-               };
-
-               mmc0: mmc@01c0f000 {
-                       pinctrl-names = "default", "default";
-                       pinctrl-0 = <&mmc0_pins_a>;
-                       pinctrl-1 = <&mmc0_cd_pin_reference_design>;
-                       cd-gpios = <&pio 7 1 0>; /* PH1 */
-                       status = "okay";
-               };
-
-               usbphy: phy@01c13400 {
-                       usb1_vbus-supply = <&reg_usb1_vbus>;
-                       usb2_vbus-supply = <&reg_usb2_vbus>;
-                       status = "okay";
-               };
-
-               ehci0: usb@01c14000 {
-                       status = "okay";
-               };
-
-               ohci0: usb@01c14400 {
-                       status = "okay";
-               };
-
-               ahci: sata@01c18000 {
-                       target-supply = <&reg_ahci_5v>;
-                       status = "okay";
-               };
-
-               ehci1: usb@01c1c000 {
-                       status = "okay";
-               };
-
-               ohci1: usb@01c1c400 {
-                       status = "okay";
-               };
-
-               pinctrl@01c20800 {
-                       led_pins_pcduino3: led_pins@0 {
-                               allwinner,pins = "PH2";
-                               allwinner,function = "gpio_out";
-                               allwinner,drive = <1>;
-                               allwinner,pull = <0>;
-                       };
-               };
-
-               lradc: lradc@01c22800 {
-                       allwinner,chan0-step = <200>;
-                       linux,chan0-keycodes = <KEY_VOLUMEUP KEY_VOLUMEDOWN
-                                               KEY_MENU KEY_SEARCH KEY_HOME
-                                               KEY_ESC KEY_ENTER>;
-                       status = "okay";
-               };
-
-               uart0: serial@01c28000 {
-                       pinctrl-names = "default";
-                       pinctrl-0 = <&uart0_pins_a>;
-                       status = "okay";
-               };
-
-               uart6: serial@01c29800 {
-                       pinctrl-names = "default";
-                       pinctrl-0 = <&uart6_pins_a>;
-                       status = "okay";
-               };
-
-               uart7: serial@01c29c00 {
-                       pinctrl-names = "default";
-                       pinctrl-0 = <&uart7_pins_a>;
-                       status = "okay";
-               };
-
-               i2c0: i2c@01c2ac00 {
-                       pinctrl-names = "default";
-                       pinctrl-0 = <&i2c0_pins_a>;
-                       status = "okay";
-               };
-
-               i2c1: i2c@01c2b000 {
-                       pinctrl-names = "default";
-                       pinctrl-0 = <&i2c1_pins_a>;
-                       status = "okay";
-               };
-
-               i2c2: i2c@01c2b400 {
-                       pinctrl-names = "default";
-                       pinctrl-0 = <&i2c2_pins_a>;
-                       status = "okay";
-               };
-
-               gmac: ethernet@01c50000 {
-                       pinctrl-names = "default";
-                       pinctrl-0 = <&gmac_pins_mii_a>;
-                       phy = <&phy1>;
-                       phy-mode = "mii";
-                       status = "okay";
-
-                       phy1: ethernet-phy@1 {
-                               reg = <1>;
-                       };
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-               pinctrl-names = "default";
-               pinctrl-0 = <&led_pins_pcduino3>;
-
-               green {
-                       label = "a20-pcduino:green:usr";
-                       gpios = <&pio 7 2 0>;
-                       default-state = "on";
-               };
-       };
-};
diff --git a/target/linux/sunxi/patches-3.14/300-1-dt-sun7i-add-pcduino3.patch b/target/linux/sunxi/patches-3.14/300-1-dt-sun7i-add-pcduino3.patch
new file mode 100644 (file)
index 0000000..9b84426
--- /dev/null
@@ -0,0 +1,39 @@
+From c6c022c42e6b9115cbc36dce3f9100b90c2d2b06 Mon Sep 17 00:00:00 2001
+From: Zoltan HERPAI <wigyori@uid0.hu>
+Date: Tue, 20 May 2014 22:28:49 +0200
+Subject: [PATCH] ARM: sun7i: dt: Add board support for LinkSprite pcDuino V3
+
+The LinkSprite pcDuino V3 is an A20-based revision of the
+earlier pcDuinos. This series will add support for the board,
+along with some of its devices where the driver is accepted or
+soon-to-be-accepted into mainline.
+
+Changes since v2:
+ - update MMC entry to comply with upstream
+ - unify the 4 patches into one
+
+Changes since v1:
+ - fix cosmetic issues
+ - fix i2c entry
+ - remove unnecessary input bindings include
+ - add MMC support
+
+Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
+---
+ arch/arm/boot/dts/Makefile               |   3 +-
+ arch/arm/boot/dts/sun7i-a20-pcduino3.dts | 119 +++++++++++++++++++++++++++++++
+ 2 files changed, 121 insertions(+), 1 deletion(-)
+ create mode 100644 arch/arm/boot/dts/sun7i-a20-pcduino3.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -292,7 +292,8 @@ dtb-$(CONFIG_ARCH_SUNXI) += \
+       sun6i-a31-colombus.dtb \
+       sun7i-a20-cubieboard2.dtb \
+       sun7i-a20-cubietruck.dtb \
+-      sun7i-a20-olinuxino-micro.dtb
++      sun7i-a20-olinuxino-micro.dtb \
++      sun7i-a20-pcduino3.dtb
+ dtb-$(CONFIG_ARCH_TEGRA) += tegra20-harmony.dtb \
+       tegra20-iris-512.dtb \
+       tegra20-medcom-wide.dtb \
diff --git a/target/linux/sunxi/patches-3.14/300-2-dt-sun7i-add-pcduino3-dts.patch b/target/linux/sunxi/patches-3.14/300-2-dt-sun7i-add-pcduino3-dts.patch
new file mode 100644 (file)
index 0000000..4ef369d
--- /dev/null
@@ -0,0 +1,159 @@
+diff -ruN old/arch/arm/boot/dts/sun7i-a20-bananapi.dts new/arch/arm/boot/dts/sun7i-a20-bananapi.dts
+diff -ruN old/arch/arm/boot/dts/sun7i-a20-cubietruck.dts new/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
+diff -ruN old/arch/arm/boot/dts/sun7i-a20-pcduino3.dts new/arch/arm/boot/dts/sun7i-a20-pcduino3.dts
+--- old/arch/arm/boot/dts/sun7i-a20-pcduino3.dts       1970-01-01 01:00:00.000000000 +0100
++++ new/arch/arm/boot/dts/sun7i-a20-pcduino3.dts       2014-10-23 15:44:48.000000000 +0200
+@@ -0,0 +1,153 @@
++/*
++ * Copyright 2014 Zoltan HERPAI
++ * Zoltan HERPAI <wigyori@uid0.hu>
++ *
++ * The code contained herein is licensed under the GNU General Public
++ * License. You may obtain a copy of the GNU General Public License
++ * Version 2 or later at the following locations:
++ *
++ * http://www.opensource.org/licenses/gpl-license.html
++ * http://www.gnu.org/copyleft/gpl.html
++ */
++
++/dts-v1/;
++/include/ "sun7i-a20.dtsi"
++/include/ "sunxi-ahci-reg.dtsi"
++/include/ "sun4i-a10-usb-vbus-reg.dtsi"
++#include <dt-bindings/input/input.h>
++
++/ {
++      model = "LinkSprite pcDuino V3";
++      compatible = "linksprite,a20-pcduino", "allwinner,sun7i-a20";
++
++      aliases {
++              spi0 = &spi1;
++              spi1 = &spi2;
++      };
++
++      soc@01c00000 {
++              spi1: spi@01c06000 {
++                      pinctrl-names = "default";
++                      pinctrl-0 = <&spi1_pins_a>;
++                      status = "okay";
++              };
++
++              spi2: spi@01c17000 {
++                      pinctrl-names = "default";
++                      pinctrl-0 = <&spi2_pins_a>;
++                      status = "okay";
++              };
++
++              mmc0: mmc@01c0f000 {
++                      pinctrl-names = "default", "default";
++                      pinctrl-0 = <&mmc0_pins_a>;
++                      pinctrl-1 = <&mmc0_cd_pin_reference_design>;
++                      cd-gpios = <&pio 7 1 0>; /* PH1 */
++                      status = "okay";
++              };
++
++              usbphy: phy@01c13400 {
++                      usb1_vbus-supply = <&reg_usb1_vbus>;
++                      usb2_vbus-supply = <&reg_usb2_vbus>;
++                      status = "okay";
++              };
++
++              ehci0: usb@01c14000 {
++                      status = "okay";
++              };
++
++              ohci0: usb@01c14400 {
++                      status = "okay";
++              };
++
++              ahci: sata@01c18000 {
++                      target-supply = <&reg_ahci_5v>;
++                      status = "okay";
++              };
++
++              ehci1: usb@01c1c000 {
++                      status = "okay";
++              };
++
++              ohci1: usb@01c1c400 {
++                      status = "okay";
++              };
++
++              pinctrl@01c20800 {
++                      led_pins_pcduino3: led_pins@0 {
++                              allwinner,pins = "PH2";
++                              allwinner,function = "gpio_out";
++                              allwinner,drive = <1>;
++                              allwinner,pull = <0>;
++                      };
++              };
++
++              lradc: lradc@01c22800 {
++                      allwinner,chan0-step = <200>;
++                      linux,chan0-keycodes = <KEY_VOLUMEUP KEY_VOLUMEDOWN
++                                              KEY_MENU KEY_SEARCH KEY_HOME
++                                              KEY_ESC KEY_ENTER>;
++                      status = "okay";
++              };
++
++              uart0: serial@01c28000 {
++                      pinctrl-names = "default";
++                      pinctrl-0 = <&uart0_pins_a>;
++                      status = "okay";
++              };
++
++              uart6: serial@01c29800 {
++                      pinctrl-names = "default";
++                      pinctrl-0 = <&uart6_pins_a>;
++                      status = "okay";
++              };
++
++              uart7: serial@01c29c00 {
++                      pinctrl-names = "default";
++                      pinctrl-0 = <&uart7_pins_a>;
++                      status = "okay";
++              };
++
++              i2c0: i2c@01c2ac00 {
++                      pinctrl-names = "default";
++                      pinctrl-0 = <&i2c0_pins_a>;
++                      status = "okay";
++              };
++
++              i2c1: i2c@01c2b000 {
++                      pinctrl-names = "default";
++                      pinctrl-0 = <&i2c1_pins_a>;
++                      status = "okay";
++              };
++
++              i2c2: i2c@01c2b400 {
++                      pinctrl-names = "default";
++                      pinctrl-0 = <&i2c2_pins_a>;
++                      status = "okay";
++              };
++
++              gmac: ethernet@01c50000 {
++                      pinctrl-names = "default";
++                      pinctrl-0 = <&gmac_pins_mii_a>;
++                      phy = <&phy1>;
++                      phy-mode = "mii";
++                      status = "okay";
++
++                      phy1: ethernet-phy@1 {
++                              reg = <1>;
++                      };
++              };
++      };
++
++      leds {
++              compatible = "gpio-leds";
++              pinctrl-names = "default";
++              pinctrl-0 = <&led_pins_pcduino3>;
++
++              green {
++                      label = "a20-pcduino:green:usr";
++                      gpios = <&pio 7 2 0>;
++                      default-state = "on";
++              };
++      };
++};
diff --git a/target/linux/sunxi/patches-3.14/300-dt-sun7i-add-pcduino3.patch b/target/linux/sunxi/patches-3.14/300-dt-sun7i-add-pcduino3.patch
deleted file mode 100644 (file)
index 9b84426..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-From c6c022c42e6b9115cbc36dce3f9100b90c2d2b06 Mon Sep 17 00:00:00 2001
-From: Zoltan HERPAI <wigyori@uid0.hu>
-Date: Tue, 20 May 2014 22:28:49 +0200
-Subject: [PATCH] ARM: sun7i: dt: Add board support for LinkSprite pcDuino V3
-
-The LinkSprite pcDuino V3 is an A20-based revision of the
-earlier pcDuinos. This series will add support for the board,
-along with some of its devices where the driver is accepted or
-soon-to-be-accepted into mainline.
-
-Changes since v2:
- - update MMC entry to comply with upstream
- - unify the 4 patches into one
-
-Changes since v1:
- - fix cosmetic issues
- - fix i2c entry
- - remove unnecessary input bindings include
- - add MMC support
-
-Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
----
- arch/arm/boot/dts/Makefile               |   3 +-
- arch/arm/boot/dts/sun7i-a20-pcduino3.dts | 119 +++++++++++++++++++++++++++++++
- 2 files changed, 121 insertions(+), 1 deletion(-)
- create mode 100644 arch/arm/boot/dts/sun7i-a20-pcduino3.dts
-
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -292,7 +292,8 @@ dtb-$(CONFIG_ARCH_SUNXI) += \
-       sun6i-a31-colombus.dtb \
-       sun7i-a20-cubieboard2.dtb \
-       sun7i-a20-cubietruck.dtb \
--      sun7i-a20-olinuxino-micro.dtb
-+      sun7i-a20-olinuxino-micro.dtb \
-+      sun7i-a20-pcduino3.dtb
- dtb-$(CONFIG_ARCH_TEGRA) += tegra20-harmony.dtb \
-       tegra20-iris-512.dtb \
-       tegra20-medcom-wide.dtb \