[package] openvpn: make comp_lzo a parameter
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Oct 2013 12:42:58 +0000 (12:42 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Oct 2013 12:42:58 +0000 (12:42 +0000)
Possible parameters are yes, no and adaptive. See manpage for more information.

Signed-off-by: Philipp Borgers <borgers@mi.fu-berlin.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38412 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/openvpn/Makefile
package/network/services/openvpn/files/openvpn.config
package/network/services/openvpn/files/openvpn.init

index 219009a..f6c4381 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=openvpn
 
 PKG_VERSION:=2.3.2
-PKG_RELEASE=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=http://swupdate.openvpn.net/community/releases
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index 4a1f667..5cf0ba6 100644 (file)
@@ -241,7 +241,7 @@ config openvpn sample_server
        # Enable compression on the VPN link.
        # If you enable it here, you must also
        # enable it in the client config file.
-       option comp_lzo 1
+       option comp_lzo yes
 
        # The maximum number of concurrently connected
        # clients we want to allow.
@@ -389,7 +389,7 @@ config openvpn sample_client
        # Enable compression on the VPN link.
        # Don't enable this unless it is also
        # enabled in the server config file.
-       option comp_lzo 1
+       option comp_lzo yes
 
        # Set log file verbosity.
        option verb 3
index eaf46c4..dee5925 100644 (file)
@@ -78,7 +78,7 @@ start_instance() {
        # append flags
        append_bools "$s" \
                auth_nocache auth_retry auth_user_pass_optional bind ccd_exclusive client client_cert_not_required \
-               client_to_client comp_lzo comp_noadapt disable \
+               client_to_client comp_noadapt disable \
                disable_occ down_pre duplicate_cn fast_io float http_proxy_retry \
                ifconfig_noexec ifconfig_nowarn ifconfig_pool_linear management_forget_disconnect management_hold \
                management_query_passwords management_signal mktun mlock mtu_test multihome mute_replay_warnings \
@@ -91,7 +91,7 @@ start_instance() {
        # append params
        append_params "$s" \
                cd askpass auth auth_user_pass auth_user_pass_verify bcast_buffers ca cert \
-               chroot cipher client_config_dir client_connect client_disconnect connect_freq \
+               chroot cipher client_config_dir client_connect client_disconnect comp_lzo connect_freq \
                connect_retry connect_timeout connect_retry_max crl_verify dev dev_node dev_type dh \
                echo engine explicit_exit_notify fragment group hand_window hash_size \
                http_proxy http_proxy_option http_proxy_timeout ifconfig ifconfig_pool \