imagebuilder: clean opkg files if requested (patch from #9866)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Aug 2011 23:58:11 +0000 (23:58 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Aug 2011 23:58:11 +0000 (23:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27872 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/imagebuilder/files/Makefile

index 002274a..902568b 100644 (file)
@@ -140,6 +140,7 @@ package_postinst: FORCE
                        IPKG_INSTROOT=$(TARGET_DIR) $(which bash) ./etc/rc.common $$script enable; \
                done || true; \
        )
+       $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/opkg)
 
 build_image: FORCE
        @echo