kernel: make libsas depend on x86
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Jul 2013 20:56:22 +0000 (20:56 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Jul 2013 20:56:22 +0000 (20:56 +0000)
It is only used by one driver that already depends on x86. Disabling it
prevents a few kilobytes of bloat from leaking into all targets via
CONFIG_BLK_DEV_BSG

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37254 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/block.mk

index 1aa47de..d92010b 100644 (file)
@@ -491,6 +491,7 @@ $(eval $(call KernelPackage,ide-it821x))
 
 define KernelPackage/libsas
   SUBMENU:=$(BLOCK_MENU)
+  DEPENDS:=@TARGET_x86
   TITLE:=SAS Domain Transport Attributes
   KCONFIG:=CONFIG_SCSI_SAS_LIBSAS \
        CONFIG_SCSI_SAS_ATTRS \