mpc85xx: use a foreach loop to copy boot images
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 20 Feb 2013 08:27:26 +0000 (08:27 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 20 Feb 2013 08:27:26 +0000 (08:27 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35689 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/mpc85xx/image/Makefile

index b762515..0826cfb 100644 (file)
@@ -8,9 +8,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 DTS_TARGETS = mpc8548cds_32b p1010rdb
+BOOT_IMAGES:=zImage
 
 define Image/Prepare
-       cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
+       $(foreach image,$(BOOT_IMAGES),
+               cp $(LINUX_DIR)/arch/powerpc/boot/$(image) $(KDIR)/$(image)
+       )
 endef
 
 define Image/BuildKernel