add a gpio feature for devices supporting the generic GPIO interface
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 Apr 2008 09:46:45 +0000 (09:46 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 Apr 2008 09:46:45 +0000 (09:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10879 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk
scripts/metadata.pl
target/Config.in

index 4f10a3d..ce842da 100644 (file)
@@ -126,6 +126,9 @@ ifeq ($(DUMP),1)
     .SILENT: $(TMP_CONFIG)
     .PRECIOUS: $(TMP_CONFIG)
 
+    ifneq ($(CONFIG_GENERIC_GPIO),)
+      FEATURES += gpio
+    endif
     ifneq ($(CONFIG_PCI),)
       FEATURES += pci
     endif
index 6d75345..51dcc42 100755 (executable)
@@ -152,6 +152,7 @@ sub target_config_features(@) {
        while ($_ = shift @_) {
                /broken/ and $ret .= "\tdepends BROKEN\n";
                /display/ and $ret .= "\tselect DISPLAY_SUPPORT\n";
+               /gpio/ and $ret .= "\tselect GPIO_SUPPORT\n";
                /pci/ and $ret .= "\tselect PCI_SUPPORT\n";
                /usb/ and $ret .= "\tselect USB_SUPPORT\n";
                /pcmcia/ and $ret .= "\tselect PCMCIA_SUPPORT\n";
index aabe9c3..505fcc9 100644 (file)
@@ -11,6 +11,9 @@ config LINUX_2_6
 config DISPLAY_SUPPORT
        bool
 
+config GPIO_SUPPORT
+       bool
+
 config PCI_SUPPORT
        bool