Package bcm63xx-pcmcia kernel module and fix compilation
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 15 Nov 2008 11:26:23 +0000 (11:26 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 15 Nov 2008 11:26:23 +0000 (11:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13212 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk
target/linux/brcm63xx/patches-2.6.27/006-pcmcia_cardbus_support.patch

index f82dfde..eacf970 100644 (file)
@@ -140,6 +140,20 @@ endef
 
 $(eval $(call KernelPackage,pcmcia-core))
 
+define KernelPackage/pcmcia-bcm63xx
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Broadcom BCM63xx PCMCIA support
+  DEPENDS:=kmod-pcmcia-core @TARGET_brcm63xx
+  KCONFIG:=CONFIG_PCMCIA_BCM63XX
+  FILES:=$(LINUX_DIR)/drivers/pcmcia/bcm63xx_pcmcia.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,bcm63xx_pcmcia)
+endef
+
+define KernelPackage/pcmcia-bcm63xx/description
+  Kernel support for PCMCIA/CardBus controller on the BCM63xx SoC
+endef
+
+$(eval $(call KernelPackage,pcmcia-bcm63xx))
 
 define KernelPackage/pcmcia-serial
   SUBMENU:=$(OTHER_MENU)
index 02fa854..5376cde 100644 (file)
@@ -188,7 +188,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
  obj-$(CONFIG_OMAP_CF)                         += omap_cf.o
 --- /dev/null
 +++ b/drivers/pcmcia/bcm63xx_pcmcia.c
-@@ -0,0 +1,521 @@
+@@ -0,0 +1,522 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive
@@ -670,6 +670,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
 +              .class          = PCI_CLASS_BRIDGE_CARDBUS << 8,
 +              .class_mask     = ~0,
 +      },
++      {}
 +};
 +
 +MODULE_DEVICE_TABLE(pci, bcm63xx_cb_table);