targets: add kernel image dependencies on device tree files
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 6 Jan 2016 18:39:06 +0000 (18:39 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 6 Jan 2016 18:39:06 +0000 (18:39 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48146 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/arc770/image/Makefile
target/linux/bcm53xx/image/Makefile
target/linux/brcm63xx/image/Makefile
target/linux/ipq806x/image/Makefile
target/linux/kirkwood/image/Makefile
target/linux/ramips/image/Makefile

index c033102..6b9c5e4 100644 (file)
@@ -15,6 +15,7 @@ endef
 # Shared device definition: applies to every defined device
 define Device/Default
   PROFILES = Default $$(DEVICE_PROFILE)
+  KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
   KERNEL_SUFFIX := .elf
   KERNEL_INITRAMFS := kernel-bin | patch-dtb
   KERNEL_INITRAMFS_NAME = $$(KERNEL_NAME)-initramfs.elf
index c9987dd..d9d4a80 100644 (file)
@@ -67,6 +67,7 @@ define Device/Default
   # extract the full dtb name based on the device info
   DT := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
   KERNEL := kernel-bin | append-dtb | lzma-d16
+  KERNEL_DEPENDS = $$(wildcard $(KDIR)/$$(DT).dts)
   FILESYSTEMS := squashfs
   KERNEL_NAME := zImage
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
index 53e4c21..81a9dc7 100644 (file)
@@ -168,6 +168,7 @@ endef
 # Shared device definition: applies to every defined device
 define Device/Default
   PROFILES = Default $$(DEVICE_PROFILE)
+  KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
   KERNEL_INITRAMFS_IMAGE = $$(KERNEL_INITRAMFS_PREFIX).elf
   DEVICE_PROFILE :=
   DEVICE_DTS :=
index 14cf442..58c4e1e 100644 (file)
@@ -42,6 +42,7 @@ endef
 
 define Device/Default
        PROFILES := Default
+       KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_INITRAMFS_PREFIX := $$(IMG_PREFIX)-$(1)-initramfs
        DEVICE_DTS :=
        KERNEL_PREFIX := $$(IMAGE_PREFIX)
index 3fc84aa..24cb317 100644 (file)
@@ -15,6 +15,7 @@ KERNEL_LOADADDR:=0x8000
 TARGET_DEVICES = linksys-audi linksys-viper
 
 define Device/Default
+  KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
   KERNEL := kernel-bin | append-dtb | uImage none
   KERNEL_NAME := zImage
 endef
index e4cbdb6..05d9795 100644 (file)
@@ -32,6 +32,7 @@ KERNEL_LOADADDR := $(loadaddr-y)
 
 KERNEL_DTB = kernel-bin | patch-dtb | lzma
 define Device/Default
+  KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)
   KERNEL := $(KERNEL_DTB) | uImage lzma
   IMAGES := sysupgrade.bin
   IMAGE_SIZE := $(ralink_default_fw_size_8M)