jffs2 root support
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Feb 2005 03:47:31 +0000 (03:47 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Feb 2005 03:47:31 +0000 (03:47 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@276 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/openwrt/jffs2root.c [new file with mode: 0644]
package/openwrt/trx.c
target/Makefile.in

diff --git a/package/openwrt/jffs2root.c b/package/openwrt/jffs2root.c
new file mode 100644 (file)
index 0000000..e74c89a
--- /dev/null
@@ -0,0 +1,108 @@
+/*
+ * jffs2root.c
+ *
+ * Copyright (C) 2005 Mike Baker 
+ *
+ * $Id$
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
+ *
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <stddef.h>
+#include <unistd.h>
+#include <fcntl.h>
+#include <sys/mman.h>
+#include <sys/stat.h>
+#include <string.h>
+
+
+#define FILENAME "/dev/mtdblock/1"
+
+struct trx_header {
+    unsigned magic;            /* "HDR0" */
+    unsigned len;              /* Length of file including header */
+    unsigned crc32;            /* 32-bit CRC from flag_version to end of file */
+    unsigned flag_version;     /* 0:15 flags, 16:31 version */
+    unsigned offsets[3];       /* Offsets of partitions from start of header */
+};
+
+unsigned long *crc32;
+
+void init_crc32()
+{
+    unsigned long crc;
+    unsigned long poly = 0xEDB88320L;
+    int n, bit;
+    crc32 = (unsigned long *) malloc(256 * sizeof(unsigned long));
+    for (n = 0; n < 256; n++) {
+       crc = (unsigned long) n;
+       for (bit = 0; bit < 8; bit++)
+           crc = (crc & 1) ? (poly ^ (crc >> 1)) : (crc >> 1);
+       crc32[n] = crc;
+    }
+}
+
+unsigned int crc32buf(char *buf, size_t len)
+{
+    unsigned int crc = 0xFFFFFFFF;
+    for (; len; len--, buf++)
+       crc = crc32[(crc ^ *buf) & 0xff] ^ (crc >> 8);
+    return crc;
+}
+
+int main(int argc, char **argv)
+{
+    int fd;
+    unsigned long len;
+    struct trx_header *ptr;
+    if (((fd = open(FILENAME, O_RDWR))  < 0)
+    || ((len = lseek(fd, 0, SEEK_END)) < 0)
+    || ((ptr = (struct trx_header *) mmap(0, len, PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0)) == (void *) (-1))
+    || (ptr->magic != 0x30524448)) {
+       printf("Error reading trx info\n");
+       exit(-1);
+    }
+
+    if (argc > 1 && !strcmp(argv[1],"--move")) {
+      if (ptr->offsets[1] >= ptr->len) {
+        printf("Partition already moved outside trx\n");
+      } else if (ptr->offsets[1] & 0x0001ffff) {
+        printf("Partition does not start on a block boundary\n");
+      } else {
+       init_crc32();
+       bzero((void *)((int)ptr + ptr->len), (size_t)(len - ptr->len));
+        ptr->len = ptr->offsets[1];
+        ptr->crc32 = crc32buf((void *) &(ptr->flag_version), ptr->len - offsetof(struct trx_header, flag_version));
+       msync(ptr,len,MS_SYNC|MS_INVALIDATE);
+       printf("Partition moved; please reboot\n");
+      }
+    } else {
+      int x;
+      printf("=== trx ===\n");
+      printf("mapped: 0x%08x\n", (unsigned)ptr);
+      printf(" magic: 0x%08x\n", ptr->magic);
+      printf("   len: 0x%08x\n", ptr->len);
+      printf("   crc: 0x%08x\n", ptr->crc32);
+      for (x = 0; x < 3; x++)
+       printf(" offset[%d]: 0x%08x\n", x, ptr->offsets[x]);
+    }
+
+
+    munmap((void *) ptr, sizeof(struct trx_header));
+    return 0;
+}
index 05a6604..d4ad600 100644 (file)
@@ -180,11 +180,12 @@ int main(int argc, char **argv)
                        case 'b':
                                n = atoi(optarg);
                                if (n < cur_len) {
-                                       fprintf(stderr, "WARNING: current length exceeds -b %d offset",n);
+                                       fprintf(stderr, "WARNING: current length exceeds -b %d offset\n",n);
                                } else {
                                        memset(buf + cur_len, 0, n - cur_len);
                                        cur_len = n;
                                }
+                               break;
                        default:
                                usage();
                }
index 40c9a05..7a212e4 100644 (file)
@@ -5,8 +5,13 @@ TARGET_SKEL_DIR=target/default/target_skeleton
 
 include target/device/Makefile.in
 
+ifeq ($(strip $(BR2_TARGET_ROOTFS_JFFS2)),y)
+JFFS2FLAGS+=-a 131072
+endif
+
+
 $(DIST)-linux.trx: openwrt-trx
-       PATH=$(TARGET_PATH) trx -o $(DIST)-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFS)
+       PATH=$(TARGET_PATH) trx -o $(DIST)-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(JFFS2FLAGS) $(IMAGE).$(ROOTFS)
 
 $(DIST)-gs-code.bin: openwrt-addpattern $(DIST)-linux.trx
        PATH=$(TARGET_PATH) addpattern -2 -i  $(DIST)-linux.trx -o $(DIST)-gs-code.bin -g