only squash owners, not permissions, when generating ext2 images
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 Dec 2006 14:44:27 +0000 (14:44 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 Dec 2006 14:44:27 +0000 (14:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5934 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 1c36327..702434e 100644 (file)
@@ -56,7 +56,7 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
   
   define Image/mkfs/ext2
-               $(STAGING_DIR)/bin/genext2fs -q -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(STAGING_DIR)/bin/genext2fs -U -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
                $(call Image/Build,ext2)
   endef
 endif