rules.mk: MIPS16 builds get a different toolchain
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 5 Apr 2013 12:35:56 +0000 (12:35 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 5 Apr 2013 12:35:56 +0000 (12:35 +0000)
To be safe, build "m16" into the toolchain and target architecture the
same way mips32r2 does:

target-mips_r2_m16_uClibc-0.9.33.2
toolchain-mips_r2_m16_gcc-4.6-linaro_uClibc-0.9.33.2

Signed-off-by: Jay Carlson <nop@nop.com>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36198 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk

index ae7a840..59ab50b 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -65,6 +65,7 @@ ifneq ($(filter -mips%r2,$(TARGET_OPTIMIZATION)),)
 endif
 ifneq ($(findstring -mips16,$(TARGET_OPTIMIZATION)),)
   TARGET_ASFLAGS_OVERRIDE:=-mno-mips16
+  ARCH_SUFFIX:= $(ARCH_SUFFIX)_m16
 endif
 ifdef CONFIG_HAS_SPE_FPU
   TARGET_SUFFIX:=$(TARGET_SUFFIX)spe