atheros: remove static gpio_request() from board setup and include generic kmod-gpio...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 May 2013 11:46:53 +0000 (11:46 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 May 2013 11:46:53 +0000 (11:46 +0000)
This change is based on a patch by Karl Palsson <karlp@remake.is>
See http://patchwork.openwrt.org/patch/3536/.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36513 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/atheros/Makefile
target/linux/atheros/patches-3.8/100-board.patch

index c7e9f84..1748f24 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,7 @@ LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Atheros SoC boards
index 56c1f69..8663156 100644 (file)
 +
 --- /dev/null
 +++ b/arch/mips/ar231x/ar2315.c
-@@ -0,0 +1,694 @@
+@@ -0,0 +1,692 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive
 +      if (!is_2315())
 +              return;
 +
-+      gpio_request(AR2315_RESET_GPIO, "reset");
-+
 +      /* Clear any lingering AHB errors */
 +      config = read_c0_config();
 +      write_c0_config(config & ~0x3);