sunxi: reorganize kmod-ata-sunxi dependencies
authorwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Aug 2015 10:08:07 +0000 (10:08 +0000)
committerwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Aug 2015 10:08:07 +0000 (10:08 +0000)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46702 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/sunxi/modules.mk

index a4c71b9..0981fe5 100644 (file)
@@ -61,10 +61,8 @@ $(eval $(call KernelPackage,eeprom-sunxi))
 define KernelPackage/ata-sunxi
     TITLE:=AllWinner sunXi AHCI SATA support
     SUBMENU:=$(BLOCK_MENU)
-    DEPENDS:=@TARGET_sunxi +kmod-scsi-core
-    KCONFIG:=\
-       CONFIG_AHCI_SUNXI \
-       CONFIG_SATA_AHCI_PLATFORM
+    DEPENDS:=@TARGET_sunxi +kmod-ata-ahci-platform +kmod-scsi-core
+    KCONFIG:=CONFIG_AHCI_SUNXI
     FILES:=$(LINUX_DIR)/drivers/ata/ahci_sunxi.ko
     AUTOLOAD:=$(call AutoLoad,41,ahci_sunxi,1)
 endef