include/cmake.mk: Add helper macro to handle conditionals for CMake boolean type...
authoracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Apr 2016 20:21:38 +0000 (20:21 +0000)
committeracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Apr 2016 20:21:38 +0000 (20:21 +0000)
Signed-off-by: Vasilis Tsiligiannis <acinonyx@openwrt.gr>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49164 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/cmake.mk

index a15cf3a..009c6c2 100644 (file)
@@ -1,3 +1,5 @@
+cmake_bool = $(patsubst %,-D%:BOOL=$(if $($(1)),ON,OFF),$(2))
+
 PKG_INSTALL:=1
 
 ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)