[brcm63xx] Fixed Comtrend CT536_CT5621 board settings. These boards are based on...
authorcshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Dec 2010 18:59:58 +0000 (18:59 +0000)
committercshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Dec 2010 18:59:58 +0000 (18:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24442 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/base-files/etc/defconfig/CT536_CT5621/network [new file with mode: 0644]
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-2.6.35/440-new_96348gw-11_leds.patch [new file with mode: 0644]

diff --git a/target/linux/brcm63xx/base-files/etc/defconfig/CT536_CT5621/network b/target/linux/brcm63xx/base-files/etc/defconfig/CT536_CT5621/network
new file mode 100644 (file)
index 0000000..a35fd2e
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright (C) 2006 OpenWrt.org
+
+config interface loopback
+       option ifname   lo
+       option proto    static
+       option ipaddr   127.0.0.1
+       option netmask  255.0.0.0
+
+config interface lan
+       option ifname   eth0
+       option type     bridge
+       option proto    static
+       option ipaddr   192.168.1.1
+       option netmask  255.255.255.0
index e2c5634..71c1880 100755 (executable)
@@ -34,6 +34,11 @@ brcm63xx_detect() {
                brcm63xx_has_reset_button="true"
                ifname=eth1
                ;;
+       "bcm63xx/CT536_CT5621 "*)
+               status_led="power"
+               brcm63xx_has_reset_button="true"
+               ifname=eth0
+               ;;
        "bcm63xx/96358GW "* | "bcm63xx/SPW500V "*)
                status_led="power:green"
                brcm63xx_has_reset_button="true"
index 25c9b36..b34c7eb 100644 (file)
@@ -128,6 +128,8 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96348GW,6348,96348GW-bc221,,--layoutver 5)
        $(call Image/Build/CFE,$(1),6338GW,6338,6338GW-generic,,)
        $(call Image/Build/CFE,$(1),6338W,6338,6338W-generic,,)
+       $(call Image/Build/CFE,$(1),96348GW-11,6348,96348GW-11-gen)
+       $(call Image/Build/CFE,$(1),96348GW-10,6348,96348GW-10-gen)
 
        # BT Voyager V210_BTR
        $(call Image/Build/CFE,$(1),V210_BB,6348,BTV210_BTR,,--layoutver 5)
@@ -152,7 +154,7 @@ define Image/Build
        # Neufbox4
        $(call Image/Build/CFE,$(1),96358VW,6358,NEUFBOX4,OpenWRT-$(REVISION))
        # Comtrend 536, 5621
-       $(call Image/Build/CFE,$(1),96348GW-11,6348,CT536_CT5621)
+       $(call Image/Build/CFEFIXUP,$(1),96348GW-11,6348,CT536_CT5621)
        # Davolink DV201AMR
        $(call Image/Build/CFEOLD,$(1),DV201AMR,6348)
        # USR 9108
diff --git a/target/linux/brcm63xx/patches-2.6.35/440-new_96348gw-11_leds.patch b/target/linux/brcm63xx/patches-2.6.35/440-new_96348gw-11_leds.patch
new file mode 100644 (file)
index 0000000..e1b6342
--- /dev/null
@@ -0,0 +1,60 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -364,6 +364,49 @@ static struct board_info __initdata boar
+       },
+ };
++static struct board_info __initdata board_ct536_ct5621 = {
++      .name                           = "CT536_CT5621",
++      .expected_cpu_id                = 0x6348,
++
++      .has_uart0                      = 1,
++      .has_enet0                      = 0,
++      .has_enet1                      = 1,
++      .has_pci                        = 1,
++
++      .enet1 = {
++              .force_speed_100        = 1,
++              .force_duplex_full      = 1,
++      },
++
++      .has_ohci0 = 1,
++      .has_pccard = 1,
++      .has_ehci0 = 1,
++
++      .leds = {
++              {
++                      .name           = "adsl-fail",
++                      .gpio           = 2,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "power",
++                      .gpio           = 0,
++                      .active_low     = 1,
++                      .default_trigger = "default-on",
++              },
++      },
++      .buttons = {
++              {
++                      .desc           = "reset",
++                      .gpio           = 33,
++                      .active_low     = 1,
++                      .type           = EV_KEY,
++                      .code           = KEY_RESTART,
++                      .threshold      = 3,
++              },
++      },
++};
++
+ static struct board_info __initdata board_96348gw = {
+       .name                           = "96348GW",
+       .expected_cpu_id                = 0x6348,
+@@ -1642,6 +1685,7 @@ static const struct board_info __initdat
+       &board_rta1025w_16,
+       &board_96348_D4PW,
+       &board_spw500v,
++      &board_ct536_ct5621,
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6358