kernel: make kmod-thermal dependency conditional to match upstream kernel module...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Dec 2015 11:43:18 +0000 (11:43 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Dec 2015 11:43:18 +0000 (11:43 +0000)
Signed-off-by: Sebastian Careba <nitroshift@yahoo.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47968 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/hwmon.mk

index e09efa1..93d7a77 100644 (file)
@@ -289,7 +289,7 @@ define KernelPackage/hwmon-pwmfan
   KCONFIG:=CONFIG_SENSORS_PWM_FAN
   FILES:=$(LINUX_DIR)/drivers/hwmon/pwm-fan.ko
   AUTOLOAD:=$(call AutoLoad,60,pwm-fan)
-  $(call AddDepends/hwmon,)
+  $(call AddDepends/hwmon, +PACKAGE_kmod-thermal:kmod-thermal)
 endef
 
 define KernelPackage/hwmon-pwmfan/description