kirkwood: update support for iconnect
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 15 Feb 2014 23:53:08 +0000 (23:53 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 15 Feb 2014 23:53:08 +0000 (23:53 +0000)
Previous patch was pushed due to false user report. While at it fix alphabetic
ordering.

The board is optimized for ubi(fs) and boots OpenWrt without changes to uboot
environment if OpenWrt's uboot package is used. In order to flash the image run
following commands in uboot shell:

nand erase 0x200000 0x1fe00000
ubi part root ; ubi remove rootfs ; ubi create rootfs
tftpboot 0x800000 openwrt-kirkwood-iconnect-rootfs.ubifs ; ubi write 0x800000 rootfs ${filesize} ; reset

Signed-off-by: Luka Perkov <luka@openwrt.org>
CC: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39591 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/kirkwood/base-files/etc/uci-defaults/02_network
target/linux/kirkwood/image/Makefile
target/linux/kirkwood/patches-3.10/130-iconnect.patch [new file with mode: 0644]
target/linux/kirkwood/profiles/110-nas.mk

index bf95f72..c6ceff7 100644 (file)
@@ -28,7 +28,9 @@ case "`cat /proc/device-tree/model`" in
 "Seagate FreeAgent Dockstar")
        set_lan_dhcp "eth0"
        ;;
-
+"Iomega Iconnect")
+       set_lan_dhcp "eth0"
+       ;;
 "RaidSonic ICY BOX IB-NAS62x0 (Rev B)")
        set_lan_dhcp "eth0"
        ;;
index 11b28fd..d7ace45 100644 (file)
@@ -117,12 +117,12 @@ Image/InstallKernel/Template/Generic=$(call Image/InstallKernel/Template)
 Image/BuildKernel/Template/DOCKSTAR=$(call Image/BuildKernel/Template,dockstar)
 Image/InstallKernel/Template/DOCKSTAR=$(call Image/InstallKernel/Template,dockstar)
 
-Image/BuildKernel/Template/ICONNECT=$(call Image/BuildKernel/Template,iconnect)
-Image/InstallKernel/Template/ICONNECT=$(call Image/InstallKernel/Template,iconnect)
-
 Image/BuildKernel/Template/IB62X0=$(call Image/BuildKernel/Template,ib62x0)
 Image/InstallKernel/Template/IB62X0=$(call Image/InstallKernel/Template,ib62x0)
 
+Image/BuildKernel/Template/ICONNECT=$(call Image/BuildKernel/Template,iconnect)
+Image/InstallKernel/Template/ICONNECT=$(call Image/InstallKernel/Template,iconnect)
+
 Image/BuildKernel/Template/POGOE02=$(call Image/BuildKernel/Template,pogo_e02)
 Image/InstallKernel/Template/POGOE02=$(call Image/InstallKernel/Template,pogo_e02)
 
diff --git a/target/linux/kirkwood/patches-3.10/130-iconnect.patch b/target/linux/kirkwood/patches-3.10/130-iconnect.patch
new file mode 100644 (file)
index 0000000..28e7012
--- /dev/null
@@ -0,0 +1,41 @@
+--- a/arch/arm/boot/dts/kirkwood-iconnect.dts
++++ b/arch/arm/boot/dts/kirkwood-iconnect.dts
+@@ -85,28 +85,23 @@
+                       status = "okay";
+                       partition@0 {
+-                              label = "uboot";
+-                              reg = <0x0000000 0xc0000>;
++                              label = "u-boot";
++                              reg = <0x0000000 0xe0000>;
+                       };
+-                      partition@a0000 {
+-                              label = "env";
+-                              reg = <0xa0000 0x20000>;
++                      partition@e0000 {
++                              label = "u-boot environment";
++                              reg = <0xe0000 0x100000>;
+                       };
+                       partition@100000 {
+-                              label = "zImage";
+-                              reg = <0x100000 0x300000>;
++                              label = "second stage u-boot";
++                              reg = <0x100000 0x200000>;
+                       };
+-                      partition@540000 {
+-                              label = "initrd";
+-                              reg = <0x540000 0x300000>;
+-                      };
+-
+-                      partition@980000 {
+-                              label = "boot";
+-                              reg = <0x980000 0x1f400000>;
++                      partition@200000 {
++                              label = "root";
++                              reg = <0x200000 0x1fe00000>;
+                       };
+               };
index 07a9797..6605f69 100644 (file)
@@ -22,21 +22,6 @@ DOCKSTAR_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
 
 $(eval $(call Profile,DOCKSTAR))
 
-define Profile/ICONNECT
-  NAME:=Iomega Iconnect
-  PACKAGES:= \
-       kmod-usb2 kmod-usb-storage
-endef
-
-define Profile/ICONNECT/Description
- Package set compatible with Iomega Iconnect board.
-endef
-
-ICONNECT_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
-ICONNECT_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
-
-$(eval $(call Profile,ICONNECT))
-
 define Profile/IB62X0
   NAME:=RaidSonic ICY BOX IB-NAS62x0
   PACKAGES:= \
@@ -53,3 +38,18 @@ IB62X0_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
 IB62X0_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
 
 $(eval $(call Profile,IB62X0))
+
+define Profile/ICONNECT
+  NAME:=Iomega Iconnect
+  PACKAGES:= \
+       kmod-usb2 kmod-usb-storage
+endef
+
+define Profile/ICONNECT/Description
+ Package set compatible with Iomega Iconnect board.
+endef
+
+ICONNECT_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+ICONNECT_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,ICONNECT))