Added hci_usb to kmod-bluetooth. Closes #316
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Feb 2006 14:58:45 +0000 (14:58 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Feb 2006 14:58:45 +0000 (14:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3263 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/aruba-2.6/config
target/linux/brcm-2.6/config
target/linux/generic-2.6/modules.mk
target/linux/x86-2.6/config

index afda3fa..f560d7e 100644 (file)
@@ -469,7 +469,8 @@ CONFIG_BT_HIDP=m
 #
 # Bluetooth device drivers
 #
-# CONFIG_BT_HCIUSB is not set
+CONFIG_BT_HCIUSB=m
+CONFIG_BT_HCIUSB_SCO=y
 CONFIG_BT_HCIUART=m
 CONFIG_BT_HCIUART_H4=y
 CONFIG_BT_HCIUART_BCSP=y
index 303d8fd..2cadc57 100644 (file)
@@ -562,7 +562,8 @@ CONFIG_BT_HIDP=m
 #
 # Bluetooth device drivers
 #
-# CONFIG_BT_HCIUSB is not set
+CONFIG_BT_HCIUSB=m
+CONFIG_BT_HCIUSB_SCO=y
 CONFIG_BT_HCIUART=m
 CONFIG_BT_HCIUART_H4=y
 CONFIG_BT_HCIUART_BCSP=y
index 4e8d2e9..37d7094 100644 (file)
@@ -342,6 +342,7 @@ $(eval $(call KMOD_template,BLUETOOTH,bluetooth,\
        $(MODULES_DIR)/kernel/net/bluetooth/sco.ko \
        $(MODULES_DIR)/kernel/net/bluetooth/rfcomm/rfcomm.ko \
        $(MODULES_DIR)/kernel/drivers/bluetooth/hci_uart.ko \
+       $(MODULES_DIR)/kernel/drivers/bluetooth/hci_usb.ko \
 ,CONFIG_BT))
 
 
index 5347e6b..339972b 100644 (file)
@@ -592,7 +592,8 @@ CONFIG_BT_HIDP=m
 #
 # Bluetooth device drivers
 #
-# CONFIG_BT_HCIUSB is not set
+CONFIG_BT_HCIUSB=m
+CONFIG_BT_HCIUSB_SCO=y
 CONFIG_BT_HCIUART=m
 CONFIG_BT_HCIUART_H4=y
 CONFIG_BT_HCIUART_BCSP=y