move zd1211 from target/linux/package/ to package/.
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 17 Jun 2006 14:46:26 +0000 (14:46 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 17 Jun 2006 14:46:26 +0000 (14:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3973 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/zd1211/Makefile [new file with mode: 0644]
target/linux/package/zd1211/Config.in [deleted file]
target/linux/package/zd1211/Makefile [deleted file]
target/linux/package/zd1211/ipkg/kmod-zd1211.control [deleted file]

diff --git a/package/zd1211/Makefile b/package/zd1211/Makefile
new file mode 100644 (file)
index 0000000..e73c0dc
--- /dev/null
@@ -0,0 +1,57 @@
+# $Id: Makefile 3297 2006-03-02 23:42:52Z florian $
+
+include $(TOPDIR)/rules.mk
+include $(TOPDIR)/package/kernel.mk
+
+PKG_NAME:=zd1211
+PKG_VERSION:=r69
+PKG_RELEASE:=1
+PKG_MD5SUM:=c14133a3d5b27927402a492e84d2467a
+
+PKG_SOURCE_URL:=http://zd1211.ath.cx/download/
+PKG_SOURCE:=$(PKG_NAME)-driver-$(PKG_VERSION).tgz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-driver-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+define Package/kmod-zd1211
+ SECTION:=drivers
+ CATEGORY:=Drivers
+ DEPENDS:=@LINUX_2_6
+ TITLE:=Driver for Zydas 1211 based USB devices
+ DESCRIPTION:=Driver for Zydas 1211 based USB devices \\\
+Linux driver for the ZyDAS ZD1211 802.11b/g USB-WLAN-Chip.\\\
+Initially contributed by ZyDAS, this driver is actively maintained by the \\\
+open source community.
+ URL:=http://zd1211.ath.cx/
+ VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               ARCH="$(LINUX_KARCH)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               CC="$(TARGET_CC)" \
+               CPP="$(TARGET_CC)" \
+               LD="$(TARGET_CROSS)ld" \
+               STAGING_DIR=$(STAGING_DIR) \
+               KERNELVERSION="$(KERNEL)" \
+               KERNEL_SOURCE="$(LINUX_DIR)" \
+               KDIR="$(LINUX_DIR)" \
+               all
+       $(TARGET_CC) $(PKG_BUILD_DIR)/apdbg.c -o $(PKG_BUILD_DIR)/apdbg
+endef
+
+define Package/kmod-zd1211/install
+       install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
+       $(CP) $(PKG_BUILD_DIR)/zd1211.$(LINUX_KMOD_SUFFIX) \
+               $(1)/lib/modules/$(LINUX_VERSION)/
+       install -m0755 -d $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/apdbg $(1)/usr/sbin/
+       $(CP) $(PKG_BUILD_DIR)/sta $(1)/usr/sbin/$(PKG_NAME)-sta
+endef
+
+$(eval $(call BuildPackage,kmod-zd1211))
+
diff --git a/target/linux/package/zd1211/Config.in b/target/linux/package/zd1211/Config.in
deleted file mode 100644 (file)
index cadfa4f..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-config PACKAGE_KMOD_ZD1211
-       prompt "kmod-zd12111...................... Driver for Zydas 1211 based devices"
-       tristate
-       depends LINUX_2_6
-       default m if DEVEL
-       help
-         Linux driver for the ZyDAS ZD1211 802.11b/g USB-WLAN-Chip. 
-         Initially contributed by ZyDAS, this driver is actively maintained 
-         by the open source community.
-       
-         http://zd1211.ath.cx/
diff --git a/target/linux/package/zd1211/Makefile b/target/linux/package/zd1211/Makefile
deleted file mode 100644 (file)
index e357af7..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# $Id: Makefile 3297 2006-03-02 23:42:52Z florian $
-
-include $(TOPDIR)/rules.mk
-include ../../rules.mk
-
-PKG_NAME:=zd1211
-PKG_VERSION:=r69
-PKG_RELEASE:=1
-PKG_MD5SUM:=c14133a3d5b27927402a492e84d2467a
-
-PKG_SOURCE_URL:=http://zd1211.ath.cx/download/
-PKG_SOURCE:=$(PKG_NAME)-driver-$(PKG_VERSION).tgz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-driver-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,KMOD_ZD1211,kmod-$(PKG_NAME),$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))))
-
-$(PKG_BUILD_DIR)/.configured:
-       touch $@
-
-$(PKG_BUILD_DIR)/.built: 
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               ARCH="$(LINUX_KARCH)" \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               CC="$(TARGET_CC)" \
-               CPP="$(TARGET_CC)" \
-               LD="$(TARGET_CROSS)ld" \
-               STAGING_DIR=$(STAGING_DIR) \
-               KERNELVERSION="$(KERNEL)" \
-               MODPATH="$(MODULES_DIR)" \
-               KERNEL_SOURCE="$(LINUX_DIR)" \
-               all
-       $(TARGET_CC) $(PKG_BUILD_DIR)/apdbg.c -o $(PKG_BUILD_DIR)/apdbg
-       touch $@
-
-$(IPKG_KMOD_ZD1211):
-       install -m0755 -d $(IDIR_KMOD_ZD1211)/lib/modules/$(LINUX_VERSION) \
-                         $(IDIR_KMOD_ZD1211)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/zd1211.$(LINUX_KMOD_SUFFIX) \
-               $(IDIR_KMOD_ZD1211)/lib/modules/$(LINUX_VERSION)/
-       $(CP) $(PKG_BUILD_DIR)/apdbg $(IDIR_KMOD_ZD1211)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/sta $(IDIR_KMOD_ZD1211)/usr/sbin/$(PKG_NAME)-sta
-       $(RSTRIP_KMOD) $(IDIR_KMOD_ZD1211)
-       $(IPKG_BUILD) $(IDIR_KMOD_ZD1211) $(PACKAGE_DIR)
-
diff --git a/target/linux/package/zd1211/ipkg/kmod-zd1211.control b/target/linux/package/zd1211/ipkg/kmod-zd1211.control
deleted file mode 100644 (file)
index 314fc91..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: kmod-zd1211
-Section: net
-Description: Driver for Zydas 1211 based devices.
-Priority: optional