uqmi: use -ffunction-sections and --gc-sections, reduces binary size from 57k to 29k
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Jun 2014 19:14:17 +0000 (19:14 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Jun 2014 19:14:17 +0000 (19:14 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41051 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/uqmi/Makefile

index 18e0954..027fc0d 100644 (file)
@@ -34,7 +34,9 @@ define Package/uqmi/description
 endef
 
 TARGET_CFLAGS += \
-       -I$(STAGING_DIR)/usr/include
+       -I$(STAGING_DIR)/usr/include -ffunction-sections -fdata-sections
+
+TARGET_LDFLAGS += -Wl,--gc-sections
 
 CMAKE_OPTIONS += \
        -DDEBUG=1