Generate squashfs images as well
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Apr 2007 17:10:03 +0000 (17:10 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Apr 2007 17:10:03 +0000 (17:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6800 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/rdc-2.6/image/Makefile

index 6c73308..7cb4e04 100644 (file)
@@ -11,9 +11,23 @@ define Image/Prepare
        $(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/bzImage
 endef
 
+define trxalign/jffs2-128k
+-a 0x20000
+endef
+define trxalign/jffs2-64k
+-a 0x10000
+endef
+define trxalign/squashfs
+-a 1024
+endef
+
 define Image/Build/Airlink
        touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+ifneq ($(1),squashfs)
        $(STAGING_DIR)/bin/airlink -b 1 -j 64 $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+else
+       $(STAGING_DIR)/bin/airlink -b 1 $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+endif
 endef
 
 define Image/Build