add pptp client
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Mar 2005 10:34:22 +0000 (10:34 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Mar 2005 10:34:22 +0000 (10:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@376 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Config.in
package/Makefile
package/pptp/Config.in [new file with mode: 0644]
package/pptp/Makefile [new file with mode: 0644]
package/pptp/pptp.control [new file with mode: 0644]

index 294482e..3c0db1d 100644 (file)
@@ -21,6 +21,7 @@ source "package/ebtables/Config.in"
 source "package/arptables/Config.in"
 source "package/iproute2/Config.in"
 source "package/openvpn/Config.in"
+source "package/pptp/Config.in"
 source "package/pptpd/Config.in"
 
 comment "Libraries"
index 5bf8c67..9fcdb6a 100644 (file)
@@ -18,6 +18,7 @@ package-$(BR2_PACKAGE_OPENSSL) += openssl
 package-$(BR2_PACKAGE_OPENVPN) += openvpn
 package-$(BR2_PACKAGE_PCRE) += pcre
 package-$(BR2_PACKAGE_POPT) += popt
+package-$(BR2_PACKAGE_PPTP) += pptp
 package-$(BR2_PACKAGE_PPTPD) += pptpd
 package-$(BR2_PACKAGE_IPROUTE2) += iproute2
 package-$(BR2_PACKAGE_HASERL) += haserl
diff --git a/package/pptp/Config.in b/package/pptp/Config.in
new file mode 100644 (file)
index 0000000..40c1ded
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PPTP
+       tristate "PPTP Client"
+       default m
+       select BR2_PACKAGE_KMOD_GRE
+       select BR2_PACKAGE_PPP
+       help
+         A Point-to-Point Tunneling Protocol Client 
diff --git a/package/pptp/Makefile b/package/pptp/Makefile
new file mode 100644 (file)
index 0000000..d080310
--- /dev/null
@@ -0,0 +1,50 @@
+#############################################################
+#
+# pptp client
+#
+#############################################################
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pptp
+PKG_VERSION:=1.6.0
+PKG_RELEASE:=1
+PKG_SOURCE_URL:=http://unc.dl.sourceforge.net/sourceforge/pptpclient/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE):
+        $(WGET) -P $(DL_DIR) $(PKG_SOURCE_URL)/$(PKG_SOURCE)
+
+$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(PKG_BUILD_DIR)/.unpacked
+
+$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.unpacked
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+        CC=$(TARGET_CC) \
+        CFLAGS="$(TARGET_CFLAGS)" \
+        all
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
+       mkdir -p $(PKG_IPK_DIR)/usr/sbin
+       cp -a ./ipkg/* $(PKG_IPK_DIR)/
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       cp $(PKG_BUILD_DIR)/pptp $(PKG_IPK_DIR)/usr/sbin/
+       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
+       mkdir -p $(PACKAGE_DIR)
+       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/pptp.list: $(PKG_IPK)
+       $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.unpacked
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/pptp.list
+
+clean:
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
diff --git a/package/pptp/pptp.control b/package/pptp/pptp.control
new file mode 100644 (file)
index 0000000..3919622
--- /dev/null
@@ -0,0 +1,9 @@
+Package: pptp
+Priority: optional
+Section: net
+Version: 1.6.0-1
+Architecture: mipsel
+Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
+Source: buildroot internal
+Description: a Point-to-Point Tunneling Protocol (PPTP) client
+Depends: ppp, kmod-gre