kernel: update 3.14 to 3.14.16
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 8 Aug 2014 13:38:22 +0000 (13:38 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 8 Aug 2014 13:38:22 +0000 (13:38 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42070 3c298f89-4303-0410-b956-a3cf2f4a3e73

15 files changed:
include/kernel-version.mk
target/linux/atheros/Makefile
target/linux/bcm53xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/generic/patches-3.14/100-overlayfs.patch
target/linux/generic/patches-3.14/616-net_optimize_xfrm_calls.patch
target/linux/generic/patches-3.14/921-use_preinit_as_init.patch
target/linux/mvebu/Makefile
target/linux/mxs/Makefile
target/linux/mxs/patches-3.14/100-soc-audio-support.patch
target/linux/mxs/patches-3.14/120-dt-add-i2c.patch
target/linux/mxs/patches-3.14/130-mxs-mmc-fix-card-detect.patch
target/linux/mxs/patches-3.14/200-duckbill.patch
target/linux/x86_64/Makefile
target/linux/x86_64/config-default

index 2cdd5bf..7023ff0 100644 (file)
@@ -20,8 +20,8 @@ endif
 ifeq ($(LINUX_VERSION),3.13.7)
   LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
 endif
-ifeq ($(LINUX_VERSION),3.14.14)
-  LINUX_KERNEL_MD5SUM:=aeea3b29cc823ada11270cfc23a27ae6
+ifeq ($(LINUX_VERSION),3.14.16)
+  LINUX_KERNEL_MD5SUM:=469c879236ed694f60b81122e91ca02e
 endif
 
 # disable the md5sum check for unknown kernel versions
index ccda090..0062b6e 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.14.14
+LINUX_VERSION:=3.14.16
 
 include $(INCLUDE_DIR)/target.mk
 
index e8e8b43..023ce4e 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 
-LINUX_VERSION:=3.14.14
+LINUX_VERSION:=3.14.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 36bf845..fb00300 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs usb atm pci pcmcia usbgadget
-LINUX_VERSION:=3.14.14
+LINUX_VERSION:=3.14.16
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 2983484..45cdd50 100644 (file)
  
  /**
   * sb_permission - Check superblock-level permissions
-@@ -3036,9 +3037,12 @@ finish_open_created:
+@@ -3037,9 +3038,12 @@ finish_open_created:
        error = may_open(&nd->path, acc_mode, open_flag);
        if (error)
                goto out;
index 088d32d..a4e4157 100644 (file)
@@ -10,4 +10,3 @@
        err = xfrm_decode_session(skb, &fl, family);
        if (err < 0)
                return err;
-
index 64c4ce2..df703a7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -868,7 +868,8 @@ static int __ref kernel_init(void *unuse
+@@ -872,7 +872,8 @@ static int __ref kernel_init(void *unuse
                pr_err("Failed to execute %s (error %d).  Attempting defaults...\n",
                        execute_command, ret);
        }
index 59cc940..ac3fc7c 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.14.14
+LINUX_VERSION:=3.14.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 1c68c99..c6cd0ce 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=ext4 rtc usb gpio
 CPU_TYPE:=arm926ej-s
 
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.14.14
+LINUX_VERSION:=3.14.16
 KERNELNAME:="zImage dtbs"
 
 define Target/Description
index f122f1b..7297458 100644 (file)
@@ -8,7 +8,7 @@
          help
            Normally ASoC codec drivers are only built if a machine driver which
            uses them is also built since they are only usable with a machine
-@@ -534,6 +535,9 @@ config SND_SOC_WM9712
+@@ -536,6 +537,9 @@ config SND_SOC_WM9712
  config SND_SOC_WM9713
        tristate
  
index 3f89fff..50bd866 100644 (file)
@@ -40,7 +40,7 @@
                                auart0_pins_a: auart0@0 {
                                        reg = <0>;
                                        fsl,pinmux-ids = <
-@@ -443,7 +476,12 @@
+@@ -444,7 +477,12 @@
                        };
  
                        i2c@80058000 {
@@ -55,7 +55,7 @@
                                status = "disabled";
 --- a/arch/arm/boot/dts/imx23-olinuxino.dts
 +++ b/arch/arm/boot/dts/imx23-olinuxino.dts
-@@ -79,6 +79,12 @@
+@@ -73,6 +73,12 @@
                                status = "okay";
                        };
  
@@ -68,7 +68,7 @@
                        duart: serial@80070000 {
                                pinctrl-names = "default";
                                pinctrl-0 = <&duart_pins_a>;
-@@ -94,7 +100,7 @@
+@@ -88,7 +94,7 @@
                        usbphy0: usbphy@8007c000 {
                                status = "okay";
                        };
index c9754b1..1cfde83 100644 (file)
@@ -27,8 +27,6 @@ Signed-off-by: Chris Ball <chris@printf.net>
  drivers/mmc/host/mxs-mmc.c | 7 +++++++
  1 file changed, 7 insertions(+)
 
-diff --git a/drivers/mmc/host/mxs-mmc.c b/drivers/mmc/host/mxs-mmc.c
-index 073e871..babfea0 100644
 --- a/drivers/mmc/host/mxs-mmc.c
 +++ b/drivers/mmc/host/mxs-mmc.c
 @@ -70,6 +70,7 @@ struct mxs_mmc_host {
@@ -39,7 +37,7 @@ index 073e871..babfea0 100644
  };
  
  static int mxs_mmc_get_cd(struct mmc_host *mmc)
-@@ -78,6 +79,9 @@ static int mxs_mmc_get_cd(struct mmc_host *mmc)
+@@ -78,6 +79,9 @@ static int mxs_mmc_get_cd(struct mmc_hos
        struct mxs_ssp *ssp = &host->ssp;
        int present, ret;
  
@@ -49,7 +47,7 @@ index 073e871..babfea0 100644
        ret = mmc_gpio_get_cd(mmc);
        if (ret >= 0)
                return ret;
-@@ -568,6 +572,7 @@ static int mxs_mmc_probe(struct platform_device *pdev)
+@@ -568,6 +572,7 @@ static int mxs_mmc_probe(struct platform
  {
        const struct of_device_id *of_id =
                        of_match_device(mxs_mmc_dt_ids, &pdev->dev);
@@ -57,7 +55,7 @@ index 073e871..babfea0 100644
        struct mxs_mmc_host *host;
        struct mmc_host *mmc;
        struct resource *iores;
-@@ -634,6 +639,8 @@ static int mxs_mmc_probe(struct platform_device *pdev)
+@@ -634,6 +639,8 @@ static int mxs_mmc_probe(struct platform
        mmc->caps = MMC_CAP_SD_HIGHSPEED | MMC_CAP_MMC_HIGHSPEED |
                    MMC_CAP_SDIO_IRQ | MMC_CAP_NEEDS_POLL;
  
@@ -66,6 +64,3 @@ index 073e871..babfea0 100644
        mmc->f_min = 400000;
        mmc->f_max = 288000000;
  
--- 
-2.0.3
-
index f4fda02..e92e762 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -164,6 +164,7 @@ dtb-$(CONFIG_ARCH_MXS) += imx23-evk.dtb
+@@ -184,6 +184,7 @@ dtb-$(CONFIG_ARCH_MXS) += imx23-evk.dtb
        imx28-cfa10057.dtb \
        imx28-cfa10058.dtb \
        imx28-evk.dtb \
index 7e53126..d63d450 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86_64
 FEATURES:=ext4 vdi vmdk targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.14.14
+LINUX_VERSION:=3.14.16
 
 KERNELNAME:=bzImage
 
index 48145be..f3aabcb 100644 (file)
@@ -472,6 +472,7 @@ CONFIG_X86_LOCAL_APIC=y
 CONFIG_X86_MCE=y
 CONFIG_X86_MCE_AMD=y
 # CONFIG_X86_MCE_INJECT is not set
+# CONFIG_X86_16BIT is not set
 CONFIG_X86_MCE_INTEL=y
 CONFIG_X86_MCE_THRESHOLD=y
 CONFIG_X86_MINIMUM_CPU_FAMILY=64