ramips: add image for ALL0256N-8M
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 4 Oct 2012 06:34:09 +0000 (06:34 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 4 Oct 2012 06:34:09 +0000 (06:34 +0000)
The new version of the ALL0256N now got 8MB SPI NOR flash instead of 4MB.
In order to expose the whole amount of flash, add another image which contains
the corresponding GENERIC_8M mtdparts.

[juhosg: change suffix from '8m' to '8M']

Patch by: Daniel Golle <dgolle@allnet.de>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33614 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/image/Makefile

index d1204f3..f8c7806 100644 (file)
@@ -389,6 +389,7 @@ endef
 
 define Image/Build/Profile/ALL0256N
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,all0256n,ALL0256N,ttyS1,57600,spi)
 
 define Image/Build/Profile/ALL0256N
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,all0256n,ALL0256N,ttyS1,57600,spi)
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,all0256n-8M,ALL0256N,ttyS1,57600,spi)
 endef
 
 define Image/Build/Profile/ALL5002
 endef
 
 define Image/Build/Profile/ALL5002