procd: fix seccomp build on some architectures
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 16 Aug 2015 20:37:47 +0000 (20:37 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 16 Aug 2015 20:37:47 +0000 (20:37 +0000)
fix generating syscall-names.h

Sometimes the syscall number is not defined with a number but with an
offset to an other syscall and then make_syscall_h.sh created some
broken header file.

For example the bit/syscall.h from musl for i386 has this:

  #define __NR_timer_create     259
  #define __NR_timer_settime    (__NR_timer_create+1)

With this patch the resulting array looks like this:

 [259] = "timer_create",
 [(__NR_timer_create+1)] = "timer_settime",

This closes #20195.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46612 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/system/procd/Makefile

index a3b1481..2c7ea3b 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2015-07-27
+PKG_VERSION:=2015-08-16
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=370b68a9c3514ecb2fb6b814ba58e4e41f4f26c0
+PKG_SOURCE_VERSION:=0da5bf2ff222d1a499172a6e09507388676b5a08
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1