[x86] image: use internal qemu-img for vmdk and vdi images
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 Aug 2010 04:22:39 +0000 (04:22 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 Aug 2010 04:22:39 +0000 (04:22 +0000)
drop host dependencies on qemu-utils and VirtualBox

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22553 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/x86/image/Config.in
target/linux/x86/image/Makefile

index b89980c..308f85c 100644 (file)
@@ -36,8 +36,6 @@ config X86_VDI_IMAGES
        depends TARGET_x86_generic
        depends TARGET_ROOTFS_EXT2FS
        select PACKAGE_kmod-pcnet32
-       help
-         Requires VBoxManage installed on the build system.
 
 config X86_VMDK_IMAGES
        bool "Build VMware image files (VMDK)"
@@ -45,8 +43,6 @@ config X86_VMDK_IMAGES
        depends TARGET_x86_generic
        depends TARGET_ROOTFS_EXT2FS
        select PACKAGE_kmod-e1000
-       help
-         Requires qemu-img installed on the build system.
 
 
 config OLPC_BOOTSCRIPT_IMAGES
index 338c8e0..b5297bb 100644 (file)
@@ -143,7 +143,7 @@ ifneq ($(CONFIG_X86_VDI_IMAGES),)
     # left here because the image builder doesnt need these
     ifeq ($(1),ext2)
                rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
-               VBoxManage convertfromraw -format VDI \
+               qemu-img convert -f raw -O vdi \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
                # XXX: VBoxManage insists on setting perms to 0600
@@ -191,15 +191,3 @@ define Image/Build
 endef
 
 $(eval $(call BuildImage))
-
-ifneq ($(CONFIG_X86_VDI_IMAGES),)
-  $(eval $(call RequireCommand,VBoxManage, \
-       You need VBoxManage to generate VirtualBox images. \
-  ))
-endif
-
-ifneq ($(CONFIG_X86_VMDK_IMAGES),)
-  $(eval $(call RequireCommand,qemu-img, \
-       You need qemu-img to generate VMware images. \
-  ))
-endif