build: remove check for nonexistant CONFIG_TAR_VERBOSITY variable and move TAR_OPTION...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Mar 2014 15:54:03 +0000 (15:54 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Mar 2014 15:54:03 +0000 (15:54 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39979 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/unpack.mk
rules.mk

index 2d35863..2b33c4c 100644 (file)
@@ -11,6 +11,8 @@ ifneq ($(HOST_OS),Linux)
 else
   HOST_TAR:=$(TAR)
 endif
+
+TAR_OPTIONS:=-xf -
 TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
 UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
 
index 5d63227..0769a09 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -272,12 +272,6 @@ else
   DISABLE_IPV6:=--disable-ipv6
 endif
 
-ifeq ($(CONFIG_TAR_VERBOSITY),y)
-  TAR_OPTIONS:=-xvf -
-else
-  TAR_OPTIONS:=-xf -
-endif
-
 ifeq ($(CONFIG_BUILD_LOG),y)
   BUILD_LOG:=1
 endif