rpcd: update to git head
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Sep 2013 12:13:33 +0000 (12:13 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Sep 2013 12:13:33 +0000 (12:13 +0000)
- introduces persistent null session to allow access to procedures without login
- implements session.login procedure to support user logins via json-rpc

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37941 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/system/rpcd/Makefile
package/system/rpcd/files/rpcd.config [new file with mode: 0644]

index e6bf3a9..f61f93e 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rpcd
-PKG_VERSION:=2013-09-09
+PKG_VERSION:=2013-09-11
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/rpcd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=22fbf13086653cba0c60d60ceb7baba2f33a034d
+PKG_SOURCE_VERSION:=ae63188069e433c20b8add7b0fba636f36551ed0
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 
@@ -48,11 +48,19 @@ define Package/rpcd/description
  functionality to frontend programs via JSON-RPC.
 endef
 
+define Package/rpcd/conffiles
+/etc/config/rpcd
+endef
+
 define Package/rpcd/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/rpcd.init $(1)/etc/init.d/rpcd
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/rpcd $(1)/sbin/rpcd
+       $(INSTALL_DIR) $(1)/usr/share/rpcd/acl.d
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/unauthenticated.json $(1)/usr/share/rpcd/acl.d/unauthenticated.json
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/rpcd.config $(1)/etc/config/rpcd
 endef
 
 
diff --git a/package/system/rpcd/files/rpcd.config b/package/system/rpcd/files/rpcd.config
new file mode 100644 (file)
index 0000000..499ea27
--- /dev/null
@@ -0,0 +1,7 @@
+
+config login
+       option username 'root'
+       option password '$p$root'
+       list read '*'
+       list write '*'
+