ralink: add mt7620a_mt7610e profile
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Aug 2013 14:30:33 +0000 (14:30 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Aug 2013 14:30:33 +0000 (14:30 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37633 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/dts/MT7620a_MT7610e.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7620a_mt7610e_eval.dts [deleted file]
target/linux/ramips/image/Makefile

diff --git a/target/linux/ramips/dts/MT7620a_MT7610e.dts b/target/linux/ramips/dts/MT7620a_MT7610e.dts
new file mode 100644 (file)
index 0000000..0d7755b
--- /dev/null
@@ -0,0 +1,99 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+       compatible = "ralink,mt7620a-eval-board", "ralink,mt7620a-soc";
+       model = "Ralink MT7620A evaluation board";
+
+       memory@0 {
+               reg = <0x0 0x2000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       palmbus@10000000 {
+               sysc@0 {
+                       ralink,pinmux = "spi", "uartlite", "mdio", "wled", "ephy", "rgmii1", "rgmii2";
+                       ralink,gpiomux = "i2c", "jtag";
+                       ralink,uartmux = "gpio";
+                       ralink,wdtmux = <1>;
+               };
+
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+               
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "en25q64";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "en25q64";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x7b0000>;
+                               };
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               status = "okay";
+       };
+
+       gsw@10110000 {
+               status = "okay";
+               ralink,port4 = "ephy";
+       };
+
+       sdhci@10130000 {
+               status = "okay";
+       };
+
+       pcie@10140000 {
+               status = "okay";
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 12 1>;
+                       linux,code = <0x100>;
+               };
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 13 1>;
+                       linux,code = <0x101>;
+               };
+       };
+};
diff --git a/target/linux/ramips/dts/mt7620a_mt7610e_eval.dts b/target/linux/ramips/dts/mt7620a_mt7610e_eval.dts
deleted file mode 100644 (file)
index 0d7755b..0000000
+++ /dev/null
@@ -1,99 +0,0 @@
-/dts-v1/;
-
-/include/ "mt7620a.dtsi"
-
-/ {
-       compatible = "ralink,mt7620a-eval-board", "ralink,mt7620a-soc";
-       model = "Ralink MT7620A evaluation board";
-
-       memory@0 {
-               reg = <0x0 0x2000000>;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,57600";
-       };
-
-       palmbus@10000000 {
-               sysc@0 {
-                       ralink,pinmux = "spi", "uartlite", "mdio", "wled", "ephy", "rgmii1", "rgmii2";
-                       ralink,gpiomux = "i2c", "jtag";
-                       ralink,uartmux = "gpio";
-                       ralink,wdtmux = <1>;
-               };
-
-               gpio0: gpio@600 {
-                       status = "okay";
-               };
-
-               spi@b00 {
-                       status = "okay";
-               
-                       m25p80@0 {
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-                               compatible = "en25q64";
-                               reg = <0 0>;
-                               linux,modalias = "m25p80", "en25q64";
-                               spi-max-frequency = <10000000>;
-
-                               partition@0 {
-                                       label = "u-boot";
-                                       reg = <0x0 0x30000>;
-                                       read-only;
-                               };
-
-                               partition@30000 {
-                                       label = "u-boot-env";
-                                       reg = <0x30000 0x10000>;
-                                       read-only;
-                               };
-
-                               factory: partition@40000 {
-                                       label = "factory";
-                                       reg = <0x40000 0x10000>;
-                                       read-only;
-                               };
-
-                               partition@50000 {
-                                       label = "firmware";
-                                       reg = <0x50000 0x7b0000>;
-                               };
-                       };
-               };
-       };
-
-       ethernet@10100000 {
-               status = "okay";
-       };
-
-       gsw@10110000 {
-               status = "okay";
-               ralink,port4 = "ephy";
-       };
-
-       sdhci@10130000 {
-               status = "okay";
-       };
-
-       pcie@10140000 {
-               status = "okay";
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-               wps {
-                       label = "wps";
-                       gpios = <&gpio0 12 1>;
-                       linux,code = <0x100>;
-               };
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 13 1>;
-                       linux,code = <0x101>;
-               };
-       };
-};
index 04d68fe..4d841b9 100644 (file)
@@ -533,10 +533,12 @@ endif
 #
 
 Image/Build/Profile/MT7620a=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a,MT7620a)
+Image/Build/Profile/MT7620a_MT7610e=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a_mt7610e,MT7620a_MT7610e)
 
 ifeq ($(SUBTARGET),mt7620a)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/MT7620a,$(1))
+       $(call Image/Build/Profile/MT7620a_MT7610e,$(1))
 endef
 endif