[package] add dist and distcheck target (to create new source balls)
authorralph <ralph@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 31 May 2009 12:01:05 +0000 (12:01 +0000)
committerralph <ralph@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 31 May 2009 12:01:05 +0000 (12:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16230 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package-defaults.mk
include/package.mk
include/subdir.mk

index 700bc5b..1553f2f 100644 (file)
@@ -70,7 +70,7 @@ CONFIGURE_VARS = \
                LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)" \
 
 CONFIGURE_PATH = .
-CONFIGURE_CMD = ./configure
+CONFIGURE_CMD = $(CONFIGURE_PATH)/configure
 
 replace_script=$(FIND) $(1) -name $(2) | $(XARGS) chmod u+w; $(FIND) $(1) -name $(2) | $(XARGS) -n1 cp $(SCRIPT_DIR)/$(2);
 
@@ -117,3 +117,11 @@ define Build/Install/Default
                $(MAKE_INSTALL_FLAGS) \
                $(1) install;
 endef
+
+define Build/Dist/Default
+       $(call Build/Compile/Default, DESTDIR="$(PKG_BUILD_DIR)/tmp" CC="$(TARGET_CC)" dist)
+endef
+
+define Build/DistCheck/Default
+       $(call Build/Compile/Default, DESTDIR="$(PKG_BUILD_DIR)/tmp" CC="$(TARGET_CC)" distcheck)
+endef
index a351661..2280865 100644 (file)
@@ -141,6 +141,8 @@ define Build/DefaultTargets
 
   prepare: $(STAMP_PREPARED)
   configure: $(STAMP_CONFIGURED)
+  dist: $(STAMP_CONFIGURED)
+  distcheck: $(STAMP_CONFIGURED)
 endef
 
 define BuildPackage
@@ -189,6 +191,8 @@ Build/Prepare=$(call Build/Prepare/Default,)
 Build/Configure=$(call Build/Configure/Default,)
 Build/Compile=$(call Build/Compile/Default,)
 Build/Install=$(if $(PKG_INSTALL),$(call Build/Install/Default,))
+Build/Dist=$(call Build/Dist/Default,)
+Build/DistCheck=$(call Build/DistCheck/Default,)
 
 $(PACKAGE_DIR):
        mkdir -p $@
@@ -213,3 +217,9 @@ clean: clean-staging FORCE
        $(Build/Clean)
        rm -f $(STAGING_DIR)/packages/$(PKG_NAME).list $(STAGING_DIR_HOST)/packages/$(PKG_NAME).list
        rm -rf $(PKG_BUILD_DIR)
+
+dist:
+       $(Build/Dist)
+   
+distcheck:
+       $(Build/DistCheck) 
index be8c308..d93d40f 100644 (file)
@@ -5,7 +5,7 @@
 # See /LICENSE for more information.
 #
 
-SUBTARGETS:=clean download prepare compile install update refresh prereq
+SUBTARGETS:=clean download prepare compile install update refresh prereq dist distcheck
 
 subtarget-default = $(filter-out ., \
        $(if $($(1)/builddirs-$(2)),$($(1)/builddirs-$(2)), \