[ep93xx] add default and Sim.One profiles
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Jan 2012 15:00:36 +0000 (15:00 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Jan 2012 15:00:36 +0000 (15:00 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29942 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ep93xx/profiles/00-default.mk [new file with mode: 0644]
target/linux/ep93xx/profiles/01-simone.mk [new file with mode: 0644]

diff --git a/target/linux/ep93xx/profiles/00-default.mk b/target/linux/ep93xx/profiles/00-default.mk
new file mode 100644 (file)
index 0000000..1c43dc6
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+  NAME:=Default Profile
+  PACKAGES:= \
+       kmod-usb-core kmod-usb-ohci
+endef
+
+define Profile/Default/Description
+       Default package set compatible with most EP93xx-based boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/ep93xx/profiles/01-simone.mk b/target/linux/ep93xx/profiles/01-simone.mk
new file mode 100644 (file)
index 0000000..d13f37b
--- /dev/null
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Simone 
+  NAME:=Simplemachines Sim.One
+  PACKAGES:= \
+       kmod-input-core \
+       kmod-input-evdev \
+       kmod-input-keyboard-ep93xx \
+       kmod-sound-soc-ep93xx \
+       kmod-sound-soc-ep93xx-ac97 \
+       kmod-sound-soc-ep93xx-simone
+endef
+
+define Profile/Simone/Description
+       Package set compatible with the Simplemachines Sim.One board.
+endef
+$(eval $(call Profile,Simone))