lantiq: add initial support for Siemens GIGASX76X
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Sep 2013 00:50:48 +0000 (00:50 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Sep 2013 00:50:48 +0000 (00:50 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38050 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/dts/GIGASX76X.dts [new file with mode: 0644]
target/linux/lantiq/image/Makefile
target/linux/lantiq/xway/profiles/gigaset.mk [new file with mode: 0644]

diff --git a/target/linux/lantiq/dts/GIGASX76X.dts b/target/linux/lantiq/dts/GIGASX76X.dts
new file mode 100644 (file)
index 0000000..d828703
--- /dev/null
@@ -0,0 +1,119 @@
+/dts-v1/;
+
+/include/ "danube.dtsi"
+
+/ {
+       model = "GIGASX76X - Gigaset SX761,SX762,SX763";
+
+       chosen {
+               bootargs = "console=ttyLTQ0,115200 init=/etc/preinit";
+       };
+
+       memory@0 {
+               reg = <0x0 0x2000000>;
+       };
+
+       sram@1F000000 {
+               vmmc@107000 {
+                       status = "okay";
+                       gpios = <&gpiomm 1 0>;
+               };
+       };
+
+       fpi@10000000 {
+               localbus@0 {
+                       nor-boot@0 {
+                               compatible = "lantiq,nor";
+                               bank-width = <2>;
+                               reg = <0 0x0 0x2000000>;
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               partition@0 {
+                                       label = "uboot";
+                                       reg = <0x0 0x30000>;
+                               };
+
+                               partition@10000 {
+                                       label = "uboot_env";
+                                       reg = <0x30000 0x10000>;
+                               };
+
+                               partition@40000 {
+                                       label = "firmware";
+                                       reg = <0x40000 0x7c0000>;
+                               };
+                       };
+
+                       gpiomm: gpiomm@4000000 {
+                               compatible = "lantiq,gpio-mm";
+                               reg = <1 0x0 0x10 >;
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               #gpio-cells = <2>;
+                               gpio-controller;
+                               lantiq,shadow = <0x3>;
+                       };
+               };
+
+               gpio: pinmux@E100B10 {
+                       pinctrl-names = "default";
+                       pinctrl-0 = <&state_default>;
+
+                       state_default: pinmux {
+                               stp {
+                                       lantiq,groups = "stp";
+                                       lantiq,function = "stp";
+                               };
+                               pci {
+                                       lantiq,groups = "gnt1", "req1";
+                                       lantiq,function = "pci";
+                               };
+                       };
+               };
+
+               gpios: stp@E100BB0 {
+                       status = "okay";
+               };
+
+               etop@E180000 {
+                       phy-mode = "rmii";
+               };
+
+               ifxhcd@E101000 {
+                       status = "okay";
+                       gpios = <&gpio 29 0>;
+               };
+
+               pci@E105400 {
+                       status = "okay";
+                       lantiq,internal-clock;
+                       gpio-reset = <&gpio 21 0>;
+                       req-mask = <0xf>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <100>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 14 0>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               switch {
+                       gpio-export,name = "switch";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 19 0>;
+               };
+       };
+};
index 1123074..1a1631f 100644 (file)
@@ -6,7 +6,7 @@
 #
 
 # boards missing since devicetree update
 #
 
 # boards missing since devicetree update
-#EASY50712 ARV3527P GIGASX76X BTHOMEHUBV2B BTHOMEHUBV2BOPENRG
+#EASY50712 ARV3527P BTHOMEHUBV2B BTHOMEHUBV2BOPENRG
 #WBMR
 
 include $(TOPDIR)/rules.mk
 #WBMR
 
 include $(TOPDIR)/rules.mk
@@ -235,6 +235,9 @@ Image/Build/Profile/ARV752DPW=$(call Image/Build/$(1),$(1),ARV752DPW)
 Image/BuildKernel/Profile/ARV752DPW22=$(call Image/BuildKernel/Template,ARV752DPW22)
 Image/Build/Profile/ARV752DPW22=$(call Image/Build/$(1),$(1),ARV752DPW22)
 
 Image/BuildKernel/Profile/ARV752DPW22=$(call Image/BuildKernel/Template,ARV752DPW22)
 Image/Build/Profile/ARV752DPW22=$(call Image/Build/$(1),$(1),ARV752DPW22)
 
+Image/BuildKernel/Profile/GIGASX76X=$(call Image/BuildKernel/Template,GIGASX76X)
+Image/Build/Profile/GIGASX76X=$(call Image/Build/$(1),$(1),GIGASX76X)
+
 
 # AR9
 Image/BuildKernel/Profile/DGN3500=$(call Image/BuildKernel/Template,DGN3500)
 
 # AR9
 Image/BuildKernel/Profile/DGN3500=$(call Image/BuildKernel/Template,DGN3500)
diff --git a/target/linux/lantiq/xway/profiles/gigaset.mk b/target/linux/lantiq/xway/profiles/gigaset.mk
new file mode 100644 (file)
index 0000000..c6259af
--- /dev/null
@@ -0,0 +1,11 @@
+define Profile/GIGASX76X
+  NAME:=Gigaset sx76x
+  PACKAGES:= kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+        kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+        kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+        ltq-adsl-app ppp-mod-pppoe \
+        kmod-ath5k wpad-mini \
+        swconfig
+endef
+
+$(eval $(call Profile,GIGASX76X))