prefer http downloads over svn/git checkouts, remove git dependency
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Nov 2007 04:10:01 +0000 (04:10 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Nov 2007 04:10:01 +0000 (04:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9567 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/download.mk
include/prereq-build.mk

index 3c7cb7e..23f2996 100644 (file)
@@ -39,9 +39,7 @@ define DownloadMethod/default
 endef
 
 define wrap_mirror
-       @$(if $(CONFIG_LOCALMIRROR),$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ) \
-       ( $(1) ) \
-       $(if $(CONFIG_LOCALMIRROR),, || $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x")
+       @$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ( $(1) )
 endef
 
 define DownloadMethod/svn
index 9b77a1b..1e448d3 100644 (file)
@@ -119,14 +119,6 @@ $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
 
-define Require/git
-       which git-clone
-endef
-
-$(eval $(call Require,git, \
-       Please install git. \
-))
-
 $(eval $(call RequireCommand,svn, \
        Please install the subversion client. \
 ))