map: set ealen to psidlen for lw4over6
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 May 2015 10:12:15 +0000 (10:12 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 May 2015 10:12:15 +0000 (10:12 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45689 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/map/Makefile
package/network/ipv6/map/src/mapcalc.c

index 2a029f8..09ba523 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=map
 PKG_VERSION:=3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index b4b3d73..b61e157 100644 (file)
@@ -226,6 +226,9 @@ int main(int argc, char *argv[])
                if (offset < 0)
                        offset = (lw4o6) ? 0 : (legacy) ? 4 : 6;
 
+               if (lw4o6 && ealen < 0 && psidlen >= 0)
+                       ealen = psidlen;
+
                // Find PD
                struct blob_attr *c, *cur;
                unsigned rem;