resync ixp4xx 2.6.30 patches with -rc3
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 29 Apr 2009 20:52:40 +0000 (20:52 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 29 Apr 2009 20:52:40 +0000 (20:52 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15497 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ixp4xx/patches-2.6.30/090-increase_entropy_pools.patch
target/linux/ixp4xx/patches-2.6.30/191-cambria_optional_uart.patch
target/linux/ixp4xx/patches-2.6.30/295-latch_led_driver.patch
target/linux/ixp4xx/patches-2.6.30/402-ixp4xx_gpiolib.patch

index 5cf81db..bb168fa 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/char/random.c
 +++ b/drivers/char/random.c
-@@ -259,9 +259,9 @@
+@@ -263,9 +263,9 @@
  /*
   * Configuration information
   */
index 3ffe715..c7b600a 100644 (file)
        unsigned int    type;           /* If UPF_FIXED_TYPE */
 --- a/include/linux/serial_core.h
 +++ b/include/linux/serial_core.h
-@@ -270,6 +270,7 @@ struct uart_port {
+@@ -273,6 +273,7 @@ struct uart_port {
  #define UPIO_TSI              (5)                     /* Tsi108/109 type IO */
  #define UPIO_DWAPB            (6)                     /* DesignWare APB UART */
  #define UPIO_RM9000           (7)                     /* RM9000 type IO */
  
        unsigned int            read_status_mask;       /* driver specific */
        unsigned int            ignore_status_mask;     /* driver specific */
-@@ -312,6 +313,7 @@ struct uart_port {
+@@ -315,6 +316,7 @@ struct uart_port {
  
        unsigned int            mctrl;                  /* current modem ctrl settings */
        unsigned int            timeout;                /* character-based timeout */
                        uart->port.dev = port->dev;
 --- a/drivers/serial/serial_core.c
 +++ b/drivers/serial/serial_core.c
-@@ -2142,6 +2142,7 @@ uart_report_port(struct uart_driver *drv
+@@ -2138,6 +2138,7 @@ uart_report_port(struct uart_driver *drv
                snprintf(address, sizeof(address),
                         "I/O 0x%lx offset 0x%x", port->iobase, port->hub6);
                break;
        case UPIO_MEM:
        case UPIO_MEM32:
        case UPIO_AU:
-@@ -2556,6 +2557,7 @@ int uart_match_port(struct uart_port *po
+@@ -2552,6 +2553,7 @@ int uart_match_port(struct uart_port *po
        case UPIO_HUB6:
                return (port1->iobase == port2->iobase) &&
                       (port1->hub6   == port2->hub6);
index b980570..9cbf5e9 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -119,6 +119,13 @@ config LEDS_GPIO
-         outputs. To be useful the particular board must have LEDs
-         and they must be connected to the GPIO lines.
+@@ -155,6 +155,13 @@ config LEDS_LP5521
+         This driver can be built as a module by choosing 'M'. The module
+         will be called leds-lp5521.
  
 +config LEDS_LATCH
 +      tristate "LED Support for Memory Latched LEDs"
@@ -12,8 +12,8 @@
 +
 +
  config LEDS_CLEVO_MAIL
-       tristate "Mail LED on Clevo notebook (EXPERIMENTAL)"
-       depends on LEDS_CLASS && X86 && SERIO_I8042 && DMI && EXPERIMENTAL
+       tristate "Mail LED on Clevo notebook"
+       depends on LEDS_CLASS && X86 && SERIO_I8042 && DMI
 --- /dev/null
 +++ b/drivers/leds/leds-latch.c
 @@ -0,0 +1,149 @@
 +MODULE_LICENSE("GPL");
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -18,6 +18,7 @@ obj-$(CONFIG_LEDS_COBALT_RAQ)                += leds-c
+@@ -20,6 +20,7 @@ obj-$(CONFIG_LEDS_COBALT_RAQ)                += leds-c
  obj-$(CONFIG_LEDS_SUNFIRE)            += leds-sunfire.o
  obj-$(CONFIG_LEDS_PCA9532)            += leds-pca9532.o
  obj-$(CONFIG_LEDS_GPIO)                       += leds-gpio.o
  obj-$(CONFIG_LEDS_FSG)                        += leds-fsg.o
 --- a/include/linux/leds.h
 +++ b/include/linux/leds.h
-@@ -151,5 +151,19 @@ struct gpio_led_platform_data {
+@@ -153,5 +153,19 @@ struct gpio_led_platform_data {
                                        unsigned long *delay_off);
  };
  
index f0b48a5..7e296c1 100644 (file)
  
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -365,6 +365,7 @@ config ARCH_IXP4XX
+@@ -374,6 +374,7 @@ config ARCH_IXP4XX
        select GENERIC_GPIO
        select GENERIC_TIME
        select GENERIC_CLOCKEVENTS
 +      select ARCH_REQUIRE_GPIOLIB
-       select DMABOUNCE if PCI
        help
          Support for Intel's IXP4XX (XScale) family of processors.
 --- a/arch/arm/mach-ixp4xx/include/mach/gpio.h
 +++ b/arch/arm/mach-ixp4xx/include/mach/gpio.h
 @@ -27,47 +27,31 @@